[Flame][Notifications]The icons in Status bar become gray if you cancel setting up Email to share a song/contact.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.zhou, Assigned: apastor)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

[1.Description]:
[Flame][v2.2][Notifications]The icons in Notification bar become gray if you cancel setting up Email to share a song/contact.
Attachment: logcat_441.txt, 441.png and 441.mp4
Happen time:4:41 AM

[2.Testing Steps]: 
Prerequisite: Didn't set up Email account.
1. Launch Music
2. Play a song
3. Try to share the song via Email
4. Tap Cancel when the Confirmation window appear

[3.Expected Result]: 
4. The icons in Notification bar should become white.

[4.Actual Result]: 
4. The icons in Notification bar become gray

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (unaffected)
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Posted video Bug video: 441.mp4
Component: Gaia → Gaia::System
Whiteboard: [systemsfe]
blocking-b2g: --- → 2.2?
Summary: [Flame][Notifications]The icons in Notification bar become gray if you cancel setting up Email to share a song/contact. → [Flame][Notifications]The icons in Status bar become gray if you cancel setting up Email to share a song/contact.
blocking-b2g: 2.2? → 2.2+
I guess Alberto is the winner here :)
Assignee: nobody → apastor
Attachment #8590701 - Flags: review?(gmarty)
Target Milestone: --- → 2.2 S10 (17apr)
Comment on attachment 8590701 [details] [review]
[gaia] albertopq:1152238-statusbar-email-master > mozilla-b2g:master

This looks good to me, but I remember this part being very tricky, so I'd rather get another pair of eyes to look at it.
Etienne, can you take a look?
Attachment #8590701 - Flags: review?(gmarty)
Attachment #8590701 - Flags: review?(etienne)
Attachment #8590701 - Flags: feedback+
Comment on attachment 8590701 [details] [review]
[gaia] albertopq:1152238-statusbar-email-master > mozilla-b2g:master

Took a good look and this should do the trick :)

Alberto, can you make sure we have a test where Service.currentApp != Service.currentApp.getTopMostWindow(). It's important that we cover this for the inline activities use-cases and I'm not sure we are currently.

r=me with that :)
Attachment #8590701 - Flags: review?(etienne) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8590701 [details] [review]
[gaia] albertopq:1152238-statusbar-email-master > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Wrong statusbar colors on activities
[Testing completed]: Unit tests. Previous UI tests passing
[Risk to taking this patch] (and alternatives if risky): Given the number of tests we have and the importance of the bug, I think is reasonably low risk to make it land.
[String changes made]: -
Attachment #8590701 - Flags: approval-gaia-v2.2?
Attachment #8590701 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Needs rebasing for v2.2 uplift.
Flags: needinfo?(apastor)
Attached rebased patch
Flags: needinfo?(apastor)
Flags: needinfo?(hcheng)
Duplicate of this bug: 1154636
*2.2
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.201243
Firmware Date          Wed Apr 15 20:12:52 EDT 2015
Bootloader             L1TC000118D0

*master
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.