random signature unavailable due to bad access to unix fifo files

VERIFIED DUPLICATE of bug 62993

Status

MailNews Core
Composition
--
minor
VERIFIED DUPLICATE of bug 62993
17 years ago
10 years ago

People

(Reporter: Letocart Vincent, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011018
BuildID:    20011018

Anyone can get a random signature for each new mail he writes. A relevant
technique : launch a little script with a 'while' calling the fortune command
and redirect the output to a fifo file (mkfifo). But if you proceed that way,
your client freeze due to bad access to the concerned fifo file, while it works
very well with a normal file

Reproducible: Always
Steps to Reproduce:
In the mail client window :

1. Choose --> Edit/Mails and Newsgroup Account Settings...
2. Choose an account : foo@computer.com
3. Choose "Attach this signature"

Then two possibilities, giving two different behaviours :

4. Choose the "Choose Button" and find the fifo file
5. The window will never close if you stay clicking on the "Ok" button

Or :

4. Enter the name manually (Mozilla won't check th access)
5. Close the configuration with "Ok"
6. Try to compose a new mail and Mozilla freeze



Actual Results:  Depending the case, Mozilla refused the given file name, or
freeze completely and take all the CPU cycles.

Expected Results:  Accept the given file name, and access it each time I want to
compose a new mail in order to have a random signature.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

17 years ago
dup of bug 62993?

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 62993 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: sheelar → esther
verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.