Closed Bug 115259 Opened 18 years ago Closed 17 years ago

Pasting large amounts of text does not work

Categories

(SeaMonkey :: General, defect)

DEC
OpenVMS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jfarrell, Assigned: colin)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    20011205

While running the Front-end tests for Copy and Pate, I noticed that when I ran 
the "Copy Large Text" test that the test failed when I pasted the info 
into "Edit" or "Text Edit" on OpenVMS.

Reproducible: Always
Steps to Reproduce:
1.follow steps in http://www.mozilla.org/quality/browser/front-
end/testcases/copy-paste/copy-large-text/copy-large-text-d.html

Actual Results:  Nothing is pasted

Expected Results:  text should be pasted to editor

 I could NOT reproduce this on my version of Linux (I have 2001112013)
and using "gEdit 0.6.1".

 This was a problem with a large amount of text data, if I copied a
couple of words, it worked fine.

 I used "edit" on OpenVMS, which I got into by typing "edit" in a terminal 
window; and I also used "Text Editor" that I found in 
Desktop Apps.
Is the OpenVMS clipboard async by default?  This could be bug 56219....
> Is the OpenVMS clipboard async by default?

 Don't know the answer to this. Sorry.

Also noticed this was a problem with the following testbed tests
(just for reference):

http://www.mozilla.org/quality/browser/front-end/testcases/copy-paste/copy-js-
text/copy-js-text-d.html

http://www.mozilla.org/quality/browser/front-end/testcases/copy-paste/copy-
entities/copy-entities-d.html

I suspect this is connected with bug 56219 because I tried running Mozilla with 
the --sync option and then I could get something to appear in the text window 
(but not all of the text).

Marking dependant on bug 56219 rather than a duplicate of, as I want to make 
sure this problem really does go away on OpenVMS when bug 56219 is fixed.
Status: UNCONFIRMED → ASSIGNED
Depends on: 56219
Ever confirmed: true
Doing the test in comment 2,
http://www.mozilla.org/quality/browser/front-end/testcases/copy-paste/copy-js-text/copy-js-text-d.html
it works if use paste using MB2 rather than doing a COPY/PASTE.
I have found a way to make this work (using Mozilla 1.2alpha but I don't think
that's relevant). The problem I believe is that the receiving application has to
be able to receive a LARGE amount of clipboard input. Previously I was using a
DECterm and the CREATE command and that wasn't working. I just tried using a
DECterm and EDIT, and voila, the PASTE worked. It took a few moments before the
actual insertion of characters started, and several minutes for the paste to
complete, but the resultant file size is about 850KB and that's the correct size.

Marking resolved.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.