Firefox 37 Search Dropdown Menu Enter key problem

RESOLVED DUPLICATE of bug 1184220

Status

()

RESOLVED DUPLICATE of bug 1184220
3 years ago
3 years ago

People

(Reporter: fred.steiny, Unassigned)

Tracking

38 Branch
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8590264 [details]
Firefox Search Enter bug.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150402191859

Steps to reproduce:

1) Click with mouse in search bar
2) Move mouse to dropdown menu entry "Change search settings" but do not click
3) Type some text in the search bar
4) Press Enter key


Actual results:

Search settings dialog opens


Expected results:

typed text should be search by default search engine

(the move of mouse to "Change search settings" can happen accidentaly and it is an annoyance that the settings dialog is sometimes opening without my wish.
The most usecase of typing text in the search bar and press enter is to do the search)
(Reporter)

Updated

3 years ago
Component: Untriaged → Search
(Reporter)

Comment 1

3 years ago
User "Coce" from Firefox support chat could reproduce the problem but found it to be standard behavior.
(Reporter)

Updated

3 years ago
OS: Windows 7 → Windows
Hardware: x86_64 → Unspecified
Version: 37 Branch → 38 Branch
(Reporter)

Comment 2

3 years ago
Workaround: Restore old search bar behavior
browser.search.showOneOffButtons = false
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1184220
You need to log in before you can comment on or make changes to this bug.