[Followup][Permission Manager] Geolocation permission prompts display inaccurate "{{ origin }} is now fullscreen." text after a fullscreen prompt is encountered.

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: borjasalguero)

Tracking

({regression})

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing] [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8590398 [details]
Geolocation-Prompt-Screenshot.png

Description:
If the user encounters a fullscreen confirmation prompt, like the one presented when opening a YouTube video in full screen, then any subsequent Geolocation prompts will display improperly, appearing as "{{ origin }} is now fullscreen." instead of "Camera would like to know your location."  The 'More Info" option is also not available.

Note: This issue stops occurring after the device has been restarted.

Repro Steps:
1) Update a Flame to 20150409010203
2) Launch the Browser app and navigate to youtube.com
3) Select a video and watch it full screen, confirming the Full Screen confirmation prompt.
4) Launch the Camera app, observe the Geolocation prompt.

Actual:
Geolocation prompt appears as a Fullscreen prompt with debug text.

Expected:
Geolocation prompt appears properly, displaying the correct text.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150409010203
Gaia: 5dfd0460eb6e616205154b0d219aa5123bf1abb3
Gecko: 8f57f60ee58a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 10/10
See attached: screenshot, logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.2 builds
Geolocation prompt appears as a Fullscreen prompt with debug text.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150409002503
Gaia: ea735c21bfb0d78333213ff0376fce1eac89ead6
Gecko: 0efd5cdbe224
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

--------------------------------------------------------

This issue does NOT occur on Flame 2.1 builds.
Geolocation prompt appears properly, displaying the correct text.

Environmental Variables:
Device: Flame 2.1
Build ID: 20150409001200
Gaia: 87e55a7ec688138812181747f690fd188d2a0668
Gecko: b016448b6076
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1152878
(Reporter)

Comment 3

3 years ago
Created attachment 8590407 [details]
logcat-geolocation.txt
Edge case regression breaking Geolocation prompt dialogs.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150324114414
Gaia: 3be0369185070c6f4fea648afb54625a5b606899
Gecko: 891c3d50af03
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150324124914
Gaia: 4e53a69221b852c79825c9e4857d162c7b855ad5
Gecko: 73a5b0772e85
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 3be0369185070c6f4fea648afb54625a5b606899
Gecko: 73a5b0772e85
Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 4e53a69221b852c79825c9e4857d162c7b855ad5
Gecko: 891c3d50af03

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/3be0369185070c6f4fea648afb54625a5b606899...4e53a69221b852c79825c9e4857d162c7b855ad5

Caused by Bug 1144784.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Borja, can you take a look at this please? This might have been caused by the work done for bug 1144784
Blocks: 1144784
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(borja.bugzilla)

Updated

3 years ago
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing] [systemsfe]
(Assignee)

Updated

3 years ago
Assignee: nobody → borja.bugzilla
Flags: needinfo?(borja.bugzilla)
(Assignee)

Comment 7

3 years ago
Im gonna add some tests in order to identify where the bug is. I'll come back with more info asap!
(Assignee)

Updated

3 years ago
Summary: [Window Management] Geolocation permission prompts display inaccurate "{{ origin }} is now fullscreen." text after a fullscreen prompt is encountered. → [Followup][Permission Manager] Geolocation permission prompts display inaccurate "{{ origin }} is now fullscreen." text after a fullscreen prompt is encountered.
Created attachment 8590770 [details] [review]
[gaia] borjasalguero:fix_permissions_fullscreen > mozilla-b2g:master
(Assignee)

Updated

3 years ago
No longer blocks: 1144784
Depends on: 1144784
(Assignee)

Comment 9

3 years ago
Comment on attachment 8590770 [details] [review]
[gaia] borjasalguero:fix_permissions_fullscreen > mozilla-b2g:master

Hi Alive! Simple patch in order to have all scenarios working as expected. I've added one test in order to ensure that this is working as expected. Could you take a look? Thanks!
Attachment #8590770 - Flags: review?(alive)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8590770 [details] [review]
[gaia] borjasalguero:fix_permissions_fullscreen > mozilla-b2g:master

r=me with nits - if you have a good reason not to put it in cleanDialog then that's fine.
Attachment #8590770 - Flags: review?(alive) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S10 (17apr)
(Assignee)

Comment 12

3 years ago
Comment on attachment 8590770 [details] [review]
[gaia] borjasalguero:fix_permissions_fullscreen > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Follow up of https://bugzilla.mozilla.org/show_bug.cgi?id=1144784
[User impact] if declined: Fullscreen permission is not going to work when mixing with other permissions request.
[Testing completed]: Unit test added in order to ensure this scenario is working as expected.
[Risk to taking this patch] (and alternatives if risky): No risk. It's a one-line patch, simple and with unit tests.
[String changes made]: No.
Attachment #8590770 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8590770 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Keywords: verifyme
Created attachment 8592535 [details]
fixed screenshot

This issue is verified fixed on Flame 2.2 and 3.0. Following STR, the Camera permission prompt displays correctly (see attached screenshot).

Device: Flame 2.2
BuildID: 20150414002504
Gaia: 73645b097720f3ca594a14d288b87d3885d7fc9d
Gecko: 85ea1be9ac7d
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
BuildID: 20150414072436
Gaia: c8cb0c0ebb8dd1f5c0c9037e38f8e4b237beb77b
Gecko: 388f5861dc7d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.