Closed Bug 1153050 Opened 5 years ago Closed 5 years ago

Add ICameraControl check to MediaEngineGonkVideoSource::Start()

Categories

(Core :: WebRTC: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
blocking-b2g 2.2+
Tracking Status
firefox38 --- wontfix
firefox39 --- wontfix
firefox40 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(1 file, 1 obsolete file)

This bug is created based on Bug 1150271 comment 11.
blocking-b2g: --- → 2.2?
Assignee: nobody → sotaro.ikeda.g
Attachment #8590580 - Flags: review?(rjesup)
Comment on attachment 8590580 [details] [diff] [review]
Add ICameraControl check to MediaEngineGonkVideoSource::Start()

Review of attachment 8590580 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/media/webrtc/MediaEngineGonkVideoSource.cpp
@@ +223,5 @@
>  
>    if (mState == kStarted) {
>      return NS_OK;
> +  } else if (!mCameraControl) {
> +    LOG(("mCameraControl is nullptr"));

I take it this can simply happen, so we shouldn't be MOZ_ASSERT() (or NS_ASSERTION()) here?
Attachment #8590580 - Flags: review?(rjesup) → review+
Yup, I am going to add MOZ_ASSERT() here.
Apply the comment. Carry "r=jesup".
Attachment #8590580 - Attachment is obsolete: true
blocking-b2g: 2.2? → 2.2+
https://hg.mozilla.org/mozilla-central/rev/77ab3d086a13
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Comment on attachment 8590860 [details] [diff] [review]
Add ICameraControl check to MediaEngineGonkVideoSource::Start()

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: An application might crash.
Testing completed: locally tested.
Risk to taking this patch (and alternatives if risky): low. 
String or UUID changes made by this patch: none
Attachment #8590860 - Flags: approval-mozilla-b2g37?
Attachment #8590860 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.