Closed Bug 1153130 Opened 8 years ago Closed 8 years ago

Firefox crashes when pointer events are enabled

Categories

(Firefox :: Untriaged, defect)

All
Windows
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 40
Tracking Status
firefox40 --- fixed

People

(Reporter: alessarik, Assigned: alessarik)

References

(Blocks 1 open bug)

Details

Attachments

(3 files, 1 obsolete file)

Attached file exception.html
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150320202338

Steps to reproduce:

Example is attached.
Pointer events should be enabled.
Press mouse button on "logs element" and quickly move to any direction.


Actual results:

FireFox will be crashed.


Expected results:

FireFox should be live!
Some investigation:
  Call stack:
    nsINode::GetParentNode()
    nsContentUtils::ContentIsDescendantOf()
    PresShell::HandleEvent()
  Issue place:
    pointerEvent->retargetedByPointerCapture =
      frame && frame->GetContent() &&
      !nsContentUtils::ContentIsDescendantOf(frame->GetContent(), pointerCapturingContent);
Looks like frame became wrong in this place.
Possibly it happened at:
  while(CheckPointerCaptureState(pointerEvent->pointerId));
Blocks: pointerevent
OS: Windows 8 → Windows
Hardware: x86_64 → All
+ Added frame check to prevent crashes.
Attachment #8591654 - Flags: review?(bugs)
Attachment #8591654 - Flags: review?(bugs) → review+
Summary: FireFox crashes when pointer events are enabled → Firefox crashes when pointer events are enabled
Attached patch firefox_crashes_test_ver1.diff (obsolete) — Splinter Review
+ Added test into mochitest system.
Attachment #8593444 - Flags: review?(bugs)
Comment on attachment 8593444 [details] [diff] [review]
firefox_crashes_test_ver1.diff

rs+, assuming this test crashes without the patch, and doesn't with the patch.

s/FireFox/Firefox/

You could be consistent with { usage.
like, always function foobar() { and not
function barfoo() 
{
Attachment #8593444 - Flags: review?(bugs) → review+
+ Only style changes
Attachment #8593444 - Attachment is obsolete: true
Attachment #8593861 - Flags: review?(bugs)
Attachment #8593861 - Flags: review?(bugs) → review+
If everybody have no objections, I put chekin-needed flag.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fded9ab07ba2
https://hg.mozilla.org/mozilla-central/rev/830adc7b7fb3
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 40
Blocks: 1122211
You need to log in before you can comment on or make changes to this bug.