Closed Bug 1153175 Opened 5 years ago Closed 5 years ago

[Flame][FM Radio]The FM Radio will be heard in the speaker mode when tap some number in Phone.

Categories

(Firefox OS Graveyard :: Gaia::FMRadio, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1151499
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: hedan, Unassigned)

Details

Attachments

(2 files)

Attached file logcat1341.txt
[1.Description]:
[Flame v3.0][FM Radio]When the FM Radio plays in the background with headset inserted, if we tap some number in the Phone, the sound of the FM Radio will be heard from speaker.
Occur time:13:41
Attachment:logcat1341.txt &VIDEO.mp4

[2.Testing Steps]: 
1.Launch FM Radio,and plug in a headset.
2.Select a channel to play,and it can be heard in headset, then tap the home button.
3.Launch Phone ,click some digits.

[3.Expected Result]: 
3.The sound of the FM Radio should be heard from headset.

[4.Actual Result]: 
3.The sound of the FM Radio is heard from speaker.

[5.Reproduction build]: 
Device:Flame3.0 [Affected]
 Build ID               20150409160204
Gaia Revision          eaf69e651e19b98c096f8e63b9829fb31df50927
Gaia Date              2015-04-09 12:43:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd32e3ff3717
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150409.192854
Firmware Date          Thu Apr  9 19:29:11 EDT 2015
Bootloader             HHZ12d

Device: Flame 2.2 (Unaffected)
Build ID               20150409002503
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0efd5cdbe224
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150409.041814
Firmware Date          Thu Apr  9 04:18:23 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video VIDEO.mp4
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151499
You need to log in before you can comment on or make changes to this bug.