Closed Bug 1153187 Opened 5 years ago Closed 5 years ago

Build process is broken while reticulating splines "Variable SHARED_LIBRARY_LIBS" involved.

Categories

(MailNews Core :: Build Config, defect, blocker)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 40.0

People

(Reporter: fredbezies, Assigned: jsbruner)

References

Details

(Keywords: dogfood, regression)

Attachments

(2 files)

I have a bug when I try to build thunderbird from mercurial repository.

Everything goes well, until it starts "reticulating splines".

Crash log :

js/src> creating ./config.status

Reticulating splines...
Traceback (most recent call last):
  File "./config.status", line 1009, in <module>
    config_status(**args)
  File "/home/fred/logs/mail/src/mozilla/python/mozbuild/mozbuild/config_status.py", line 149, in config_status
    summary = the_backend.consume(definitions)
  File "/home/fred/logs/mail/src/mozilla/python/mozbuild/mozbuild/backend/base.py", line 200, in consume
    self.consume_finished()
  File "/home/fred/logs/mail/src/mozilla/python/mozbuild/mozbuild/backend/recursivemake.py", line 755, in consume_finished
    self._check_blacklisted_variables(makefile_in, content)
  File "/home/fred/logs/mail/src/mozilla/python/mozbuild/mozbuild/backend/recursivemake.py", line 698, in _check_blacklisted_variables
    'only be defined in moz.build files.' % (x, makefile_in))
Exception: Variable SHARED_LIBRARY_LIBS is defined in /home/fred/logs/mail/src/mailnews/import/build/Makefile.in. It should only be defined in moz.build files.
*** Fix above errors and then restart with\
               "make -f client.mk build"
/home/fred/logs/mail/src/client.mk:361: recipe for target 'configure' failed
make[1]: *** [configure] Error 1
make[1]: Leaving directory '/home/fred/logs/mail/src'
client.mk:375: recipe for target '/home/fred/logs/mail/objdir-tb/Makefile' failed
make: *** [/home/fred/logs/mail/objdir-tb/Makefile] Error 2

Build process was working yesterday.
This needs a port of the changes in bug 852814.
Blocks: 852814
OS: Linux → All
Product: Thunderbird → MailNews Core
Hardware: x86_64 → All
I think the only thing needed is part 3 of bug 1138063. I'm able to build locally with that applied, at least.
(In reply to Brian O'Keefe [:bokeefe] from comment #2)
> I think the only thing needed is part 3 of bug 1138063. I'm able to build
> locally with that applied, at least.

"This file contains only whitespace changes."
Not very useful
Severity: normal → blocker
Keywords: dogfood, regression
Maybe you were looking at the wrong part 3? I applied this one and it works:

https://hg.mozilla.org/try-comm-central/rev/a7e4571632d2

See this try build:

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=adff286f79d5

The mac try failure is due to the other patches I am testing and not related to this bug.
(In reply to Philipp Kewisch [:Fallen] from comment #4)
> Maybe you were looking at the wrong part 3? I applied this one and it works:
> 
> https://hg.mozilla.org/try-comm-central/rev/a7e4571632d2
I was looking at:
https://reviewboard.mozilla.org/r/4493/diff/1-2/
Where did you find:
https://hg.mozilla.org/try-comm-central/rev/a7e4571632d2
Duplicate of this bug: 1153559
(In reply to Philipp Kewisch [:Fallen] from comment #4)
> Maybe you were looking at the wrong part 3? I applied this one and it works:
> 
> https://hg.mozilla.org/try-comm-central/rev/a7e4571632d2

Submit a patch?
Attached patch Fix. β€” β€” Splinter Review
Attachment #8591414 - Flags: review?(Pidgeot18)
Comment on attachment 8591414 [details] [diff] [review]
Fix.

Review of attachment 8591414 [details] [diff] [review]:
-----------------------------------------------------------------

If you don't mind, I'll steal this review and land it in a moment. I can confirm it builds
Attachment #8591414 - Flags: review?(Pidgeot18) → review+
Assignee: nobody → josiah
https://hg.mozilla.org/comm-central/rev/64c2c682adb6 -> FIXED
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 40.0
So this bug is marked as the reason for the closed comm-central tree.
It seems all platforms are building now again:
https://treeherder.mozilla.org/#/jobs?repo=comm-central

Can you please open the tree? Thanks for the fix!
Comment on attachment 8591414 [details] [diff] [review]
Fix.

>+        'msgbsutl_s'
Huh, I thought the original patch had a comma here.
Add the missing comma
Attachment #8594092 - Flags: review?(neil)
Attachment #8594092 - Flags: review?(neil) → review+
You need to log in before you can comment on or make changes to this bug.