Closed Bug 1153381 Opened 5 years ago Closed 5 years ago

WebGL Google Maps rendering bugs with D3D11 ANGLE on GMA4500

Categories

(Core :: Canvas: WebGL, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox37 + verified
firefox38 + fixed
firefox39 + fixed
firefox40 + fixed
relnote-firefox --- 37+

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Details

Attachments

(3 files, 1 obsolete file)

Attached image Q45_small.jpg
I can reproduce this locally.
[Tracking Requested - why for this release]: This is 37 regression on a high profile property
OS: Mac OS X → Windows 7
Comment on attachment 8591055 [details] [diff] [review]
Blacklist D3D11 ANGLE on some Intel cards

Review of attachment 8591055 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/thebes/gfxPlatform.cpp
@@ +2267,5 @@
> +  MOZ_ASSERT(sLayersAccelerationPrefsInitialized);
> +  return sANGLESupportsD3D11;
> +}
> +
> +

Too much whitespace

::: widget/nsIGfxInfo.idl
@@ +7,5 @@
>  #include "nsISupports.idl"
>  
>  /* NOTE: this interface is completely undesigned, not stable and likely to change */
>  
> +[scriptable, uuid(74fdaac3-e5ce-4944-becc-c08c168f673c)]

Does adding constants require an uuid update?
Attachment #8591055 - Flags: review?(mstange) → review+
Comment on attachment 8591055 [details] [diff] [review]
Blacklist D3D11 ANGLE on some Intel cards

Approval Request Comment
[Feature/regressing bug #]: bug 1079398
[User impact if declined]: Somewhat broken Google Maps
[Describe test coverage new/current, TreeHerder]: I sort of tested this on a machine that's affected but it had another issue related to Nightly. I tested this on a unaffected machine and it did not have a negative impact
[Risks and why]: Should be pretty low
Attachment #8591055 - Flags: approval-mozilla-release?
Attachment #8591055 - Flags: approval-mozilla-beta?
Attachment #8591055 - Flags: approval-mozilla-aurora?
Tracking as we don't want Canada to be under water.
Assignee: nobody → jmuizelaar
https://hg.mozilla.org/mozilla-central/rev/726812ce0633
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Comment on attachment 8591055 [details] [diff] [review]
Blacklist D3D11 ANGLE on some Intel cards

Should be in beta 4.
Attachment #8591055 - Flags: approval-mozilla-beta?
Attachment #8591055 - Flags: approval-mozilla-beta+
Attachment #8591055 - Flags: approval-mozilla-aurora?
Attachment #8591055 - Flags: approval-mozilla-aurora+
Needs rebasing for Aurora/Beta uplift.
Flags: needinfo?(jmuizelaar)
Attached patch Aurora patch (obsolete) — Splinter Review
Flags: needinfo?(jmuizelaar)
The aurora patch should apply to beta.
Attachment #8591799 - Attachment is obsolete: true
Comment on attachment 8591055 [details] [diff] [review]
Blacklist D3D11 ANGLE on some Intel cards

This bug is one of the drivers for 37.0.2. Release+
Attachment #8591055 - Flags: approval-mozilla-release? → approval-mozilla-release+
We do not have the exact Graphics Card mentioned here, and we could not reproduce the issue on other Intel cards that we have available, on Windows 7 x64 and Windows 8 x64, with Firefox 37.0.1.

Jeff, could you confirm that the fix works correctly on the machine that you've reproduced this? At least for Firefox 37.0.2: https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/37.0.2-candidates/build1/.
Flags: needinfo?(jmuizelaar)
Yes this works properly on the machine that could reproduce the issue.
Flags: needinfo?(jmuizelaar)
Relnoted as "Google Maps may render incorrectly in some cases"
Flags: in-moztrap+
Flags: a11y-review+
You need to log in before you can comment on or make changes to this bug.