Closed Bug 1153491 Opened 5 years ago Closed 4 years ago

Get IndexedDB prompt tests running under e10s

Categories

(Core :: Storage: IndexedDB, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1220732
Tracking Status
e10s + ---

People

(Reporter: mrbkap, Assigned: bevis)

References

(Blocks 1 open bug)

Details

(Whiteboard: [tw-dom])

Attachments

(1 file)

The browser-chrome tests in dom/indexeddb/test don't run at all in e10s. I started converting them but don't have time to finish right now.
This also has a WIP for the second test. I am having trouble getting the button dropdown to come down for me (even before this patch, non-e10s, so this might be a local problem with my environment).
Whiteboard: [tw-dom]
I'd like to take this bug to be more familiar with IndexedDB-related implementation.
Assignee: nobody → btseng
Status: NEW → ASSIGNED
Set this bug as duplication of bug 1220732 due to the following reason:
1. The browser-chrome tests of indexeddb in e10s has been enabled without failure after bug 1220732 was fixed.
2. I also double check that these test cases are run successfully in current treeherder result of m-c[1].

Take linux opt test mochitest-e10s-browser-chrome-4 as example:
> 07:37:27     INFO -  282 INFO TEST-START | dom/indexedDB/test/browser_bug839193.js
> 07:37:29     INFO -  MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
> 07:37:29     INFO -  MEMORY STAT | vsize 684MB | residentFast 205MB | heapAllocated 97MB
> 07:37:29     INFO -  283 INFO TEST-OK | dom/indexedDB/test/browser_bug839193.js | took 2134ms
> 07:37:29     INFO -  284 INFO TEST-START | dom/indexedDB/test/browser_forgetThisSite.js
> 07:37:31     INFO -  Xlib:  extension "RANDR" missing on display ":0".
> 07:37:33     INFO -  MEMORY STAT | vsize 712MB | residentFast 195MB | heapAllocated 76MB
> 07:37:33     INFO -  285 INFO TEST-OK | dom/indexedDB/test/browser_forgetThisSite.js | took 4401ms
> 07:37:34     INFO -  286 INFO TEST-START | dom/indexedDB/test/browser_permissionsPromptAllow.js
> 07:37:35     INFO -  MEMORY STAT | vsize 714MB | residentFast 198MB | heapAllocated 79MB
> 07:37:35     INFO -  287 INFO TEST-OK | dom/indexedDB/test/browser_permissionsPromptAllow.js | took 1463ms
> 07:37:35     INFO -  288 INFO TEST-START | dom/indexedDB/test/browser_permissionsPromptDeny.js
> 07:37:37     INFO -  MEMORY STAT | vsize 787MB | residentFast 199MB | heapAllocated 81MB
> 07:37:37     INFO -  289 INFO TEST-OK | dom/indexedDB/test/browser_permissionsPromptDeny.js | took 2027ms
> 07:37:37     INFO -  290 INFO TEST-START | dom/indexedDB/test/browser_permissionsPromptWorker.js
> 07:37:39     INFO -  MEMORY STAT | vsize 787MB | residentFast 200MB | heapAllocated 82MB
> 07:37:39     INFO -  291 INFO TEST-OK | dom/indexedDB/test/browser_permissionsPromptWorker.js | took 1672ms
> 07:37:39     INFO -  292 INFO TEST-START | dom/indexedDB/test/browser_perwindow_privateBrowsing.js
> 07:37:42     INFO -  MEMORY STAT | vsize 811MB | residentFast 212MB | heapAllocated 80MB
> 07:37:42     INFO -  293 INFO TEST-OK | dom/indexedDB/test/browser_perwindow_privateBrowsing.js | took 3328ms

[1] http://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-linux/1462971250/mozilla-central_ubuntu32_vm_test-mochitest-e10s-browser-chrome-4-bm03-tests1-linux32-build16.txt.gz
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1220732
You need to log in before you can comment on or make changes to this bug.