All users were logged out of Bugzilla on October 13th, 2018

Enable MSE_H.264 and MSE_VP9 in Linux, already enabled in Windows

RESOLVED INVALID

Status

()

P5
normal
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: vishnu637, Unassigned)

Tracking

(Blocks: 1 bug)

37 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8591423 [details]
ff37mse.png

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.118 Safari/537.36

Steps to reproduce:

Since the release of Firefox 37, Mediasource extensions with H264 and WebM_VP9 were enabled in Windows platform, but they were not enabled by default in Linux. I attached a scrrenshot of the default flag settings for mediasource and mp4 but these default flags are different from the deafult flags in Windows. Is there a reason for this difference.

I was able to make the all MSE work by modifying the flags, I hope you enable it by default in Linux.
(Reporter)

Comment 1

4 years ago
The binaries I used are mozilla and not from any distro repos .
(Reporter)

Comment 2

4 years ago
Tested it on Firefox 39 , in 39 MSE_H.264 is disabled because config flag media.fragmented-mp4.exposed is set to false and MSE_WebM_VP9 does not work because media.mediasource.enabled and media.mediasource.webm.enabled are set to false.

Updated

4 years ago
Blocks: 778617
QA Whiteboard: [bugday-20150413]
Component: Untriaged → Video/Audio
Product: Firefox → Core

Updated

4 years ago
Priority: -- → P5

Comment 3

4 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150429030202

(In reply to tracer from comment #0)
> Since the release of Firefox 37, Mediasource extensions with H264 and
> WebM_VP9 were enabled in Windows platform, but they were not enabled by
> default in Linux.

MSE & WebM VP9 is not enabled by default on Windows. See bug 1135558.
MSE VP9 is not enabled for any release of Firefox. There are bugs blocking this 1093133/1115096 for example.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.