[Flame]Edge Swipe Navigation function will not work if you draw back the status bar via pressing Home key.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.zhou, Assigned: etienne)

Tracking

({regression})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

Reporter

Description

4 years ago
[1.Description]:
[Flame][v2.2&v3.0][Settings]Edge Swipe Navigation function will not work if you draw back the status bar via pressing Home key.
Attachments: logcat_533.txt and 533.mp4
Happen time: 5:33 AM

[2.Testing Steps]: 
Prerequisite: Edge Swipe Navigation function is enabled.
1. Launch any application
2. Press Home key
3. Launch another application
4. Pull down the status bar
5. Press Home key to draw back the status bar
6. Try to drag from the left or right edge of the screen to jump between apps

[3.Expected Result]: 
6. Edge Swipe Navigation function should work well.

[4.Actual Result]: 
6. Edge Swipe Navigation function doesn't work

[5.Reproduction build]: 
Flame 2.2  (Affected):
Build ID               20150412002502
Gaia Revision          cec00d643f517ffd96cde559cd3bbd43ab85816c
Gaia Date              2015-04-10 21:41:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5005522fd68e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.040730
Firmware Date          Sun Apr 12 04:07:41 EDT 2015
Bootloader             L1TC000118D0

Flame3.0  (Affected):
Build ID               20150412160203
Gaia Revision          3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gaia Date              2015-04-10 14:38:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a46652bd992
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150412.192808
Firmware Date          Sun Apr 12 19:28:21 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
Reporter

Comment 1

4 years ago
Posted video Bug video: 533.mp4
Broken functionality, regression.
blocking-b2g: --- → 2.2?
Flags: needinfo?(hochang)
Keywords: regression

Comment 3

4 years ago
redirect to Gregor
Component: Gaia::Settings → Gaia::System
Flags: needinfo?(hochang) → needinfo?(anygregor)
Summary: [Flame][Settings]Edge Swipe Navigation function will not work if you draw back the status bar via pressing Home key. → [Flame]Edge Swipe Navigation function will not work if you draw back the status bar via pressing Home key.
blocking-b2g: 2.2? → 2.2+
Etienne, can you take this one?
Flags: needinfo?(anygregor) → needinfo?(etienne)
Whiteboard: [systemsfe]
Assignee

Comment 5

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #4)
> Etienne, can you take this one?

On it :)
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Assignee

Comment 7

4 years ago
Comment on attachment 8595248 [details] [review]
[gaia] etiennesegonzac:bug-1153769 > mozilla-b2g:master

Since I know you like short reviews :)
Attachment #8595248 - Flags: review?(alive)
Attachment #8595248 - Flags: review?(alive) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 9

4 years ago
Comment on attachment 8595248 [details] [review]
[gaia] etiennesegonzac:bug-1153769 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): this was probably here for a while...
[User impact] if declined: after using the home button to close the utility tray edge gestures won't work and pressing buttons on the edge of the screen might be difficult
[Testing completed]: STR + classic edge gesture scenarios
[Risk to taking this patch] (and alternatives if risky): low (tiny patch)
[String changes made]: none
Attachment #8595248 - Flags: approval-gaia-v2.2?
Keywords: verifyme
Attachment #8595248 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v3.0.

Actual results:Sliding down notification bar and then tapping Home button,edge swipe navigation function works well.

See attachment: verified_v3.0.mp4
Reproduce rate: 0/5 

Device: Flame 3.0 build(Pass)
Build ID               20150422160203
Gaia Revision          9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gaia Date              2015-04-22 17:32:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a9311ec2dd39
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.193515
Firmware Date          Wed Apr 22 19:35:27 EDT 2015
Bootloader             L1TC000118D0
According to the STR of Comment 0,this bug has been successfully verified on latest Nightly Flame v2.2.

Actual results:Sliding down notification bar and then tapping Home button,edge swipe navigation function works well.
Reproduce rate: 0/5 

Device: Flame 2.2 build(Pass)
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.043030
Firmware Date          Sun Apr 26 04:30:42 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.