Autophone Test failure test_can_play_type_mpeg.html | audio/mpeg='' - got maybe, expected

RESOLVED FIXED in Firefox 40

Status

()

Firefox for Android
Audio/Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Tomcat, Assigned: esawin)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 40
x86
Android
Points:
---

Firefox Tracking Flags

(firefox40 fixed, firefox45 fixed)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
https://autophone.s3.amazonaws.com/pub/mozilla.org/mobile/tinderbox-builds/b2g-inbound-android-api-11/1428912278/mochitest-media-1-nexus-4-jdq39-3.log

35 INFO TEST-UNEXPECTED-FAIL | dom/media/test/test_can_play_type_mpeg.html | audio/mpeg='' - got maybe, expected
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 10

3 years ago
This particular failure occurs for Android 4.2, 4.3. Android 2.3 isn't being tested due to wifi limitations in the lab.
Blocks: 1153855
Component: Autophone → Audio/Video
Keywords: intermittent-failure
Product: Testing → Firefox for Android
Summary: Intermittent Autophone Test failure test_can_play_type_mpeg.html | audio/mpeg='' - got maybe, expected → Autophone Test failure test_can_play_type_mpeg.html | audio/mpeg='' - got maybe, expected

Updated

3 years ago
Depends on: 1153860

Updated

3 years ago
No longer depends on: 1153860
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 13

3 years ago
Created attachment 8598683 [details] [diff] [review]
test-skip-if.patch

I can't seem to get skip-if to work for me in dom/media/test/mochitest.ini

This test patch uses skip-if = true, but I've also tried to add conditions based on android_version etc.

jmaher, gbrown: Do you know what I'm doing wrong?
Attachment #8598683 - Flags: feedback?(jmaher)
Attachment #8598683 - Flags: feedback?(gbrown)
Comment on attachment 8598683 [details] [diff] [review]
test-skip-if.patch

Review of attachment 8598683 [details] [diff] [review]:
-----------------------------------------------------------------

It looks fine to me.

I wonder if there is an error somewhere else in the file (which I also don't see!) Are other skip-if's working for you? Got a log?
Attachment #8598683 - Flags: feedback?(gbrown)
Created attachment 8598759 [details] [diff] [review]
Don't try to test canPlayType() with mp3 and OmxPlugin
Attachment #8598759 - Flags: review?(ajones)
Apparently the OMX stuff sometimes fails with MP3. We're working to replace it right now anyway, so just disable the MP3 test in that case.

Try run here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=45c978389c8b
Comment on attachment 8598683 [details] [diff] [review]
test-skip-if.patch

Review of attachment 8598683 [details] [diff] [review]:
-----------------------------------------------------------------

this is puzzling- from looking at some more info from IRC- manifest parsing/filtering is not going as planned.  a bug or issue elsewhere.
Attachment #8598683 - Flags: feedback?(jmaher)
Attachment #8598759 - Flags: review?(ajones) → review+
https://hg.mozilla.org/mozilla-central/rev/aaf052288813
Assignee: nobody → snorp
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40

Comment 20

3 years ago
I'm only testing Mm on mozilla-central at the moment but I'm still getting this error after the merge.

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=dc7ec1c30943&exclusion_profile=false&filter-searchStr=autophone
Status: RESOLVED → REOPENED
Flags: needinfo?(snorp)
Resolution: FIXED → ---
Ugh. I'll take a look.
Flags: needinfo?(snorp)
Actually, esawin will take a look :)
Assignee: snorp → esawin
(Assignee)

Comment 23

3 years ago
Created attachment 8692206 [details] [diff] [review]
0001-Bug-1153803-Enable-canPlayType-test-on-Android-4.1-..patch

This should enable the test on supported versions.
Attachment #8692206 - Flags: review?(snorp)
(Assignee)

Comment 24

3 years ago
By enable I mean fix, otherwise the test expects "", but gets the correct answer "maybe".
Comment on attachment 8692206 [details] [diff] [review]
0001-Bug-1153803-Enable-canPlayType-test-on-Android-4.1-..patch

Review of attachment 8692206 [details] [diff] [review]:
-----------------------------------------------------------------

Could've sworn I wrote this patch once...
Attachment #8692206 - Flags: review?(snorp) → review+
(Reporter)

Comment 28

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2ce0b77b70e1
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.