Export strings for the extensions in separate files

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: st3fan, Assigned: st3fan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
Previously, before Either Xcode 6.3 or 6.2, the strings in the extensions would be exported to:

  Extensions/SendTo/Localizable.strings
  Extensions/ShareTo/Localizable.strings

For some reason these strings are now part of:

  Client/Localizable.strings

This is not ideal because it means we have to duplicate all strings to all targets.

I don't know if this is a bug in Xcode or if the behaviour changes. But splitting the strings up is probably the best option here.

So this bug is about adding a tableName to all NSLocalizedString() instances in the extension code. Probably simply "SendTo" and "ShareTo".
(Assignee)

Comment 1

4 years ago
https://github.com/mozilla/firefox-ios/commit/746b98f7340d5016e5667bfb199f0d56f3eb1b46
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1153157
You need to log in before you can comment on or make changes to this bug.