Closed Bug 1153851 Opened 5 years ago Closed 5 years ago

mach mochitest-devtools doesn't find tests from devtools

Categories

(Testing :: Mochitest, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jwalker, Unassigned)

References

Details

(Keywords: regression)

STR:

$ ./mach mochitest-devtools browser/devtools/commandline/test
From _tests: Kept 35331 existing; Added/updated 0; Removed 0 files and 0 directories.
Checking for orphan ssltunnel processes...
Checking for orphan xpcshell processes...
0 ERROR no tests to run using specified combination of filters: skip_if, run_if, fail_if, remove_imptest_failure_expectations, subsuite(name=None)
SUITE-START | Running 0 tests
1 ERROR no tests to run using specified combination of filters: skip_if, run_if, fail_if, remove_imptest_failure_expectations, subsuite(name=None)
TEST-INFO | checking window state
Browser Chrome Test Summary
	Passed: 0
	Failed: 0
	Todo: 0
*** End BrowserChrome Test Results ***
SUITE-END | took 0s


Expected:

<many things>
Browser Chrome Test Summary
	Passed: 3523
	Failed: 0
	Todo: 0


We *think* 0a46652bd992 worked for this morning
Severity: normal → critical
This also prevents us from running devtools tests in e10s mode and using other options like start-at, repeat, etc
Backing out https://hg.mozilla.org/mozilla-central/rev/f3e21cdfa1fc locally fixes the problem for me.  So looks like this was caused by Bug 1153413
In the meantime, you can run `hg qbackout -r f3e21cdfa1fc` if you need to be able to run the tests
This was backed out and fixed in bug 1153413, looks good now
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Component: Mochitest Chrome → Mochitest
You need to log in before you can comment on or make changes to this bug.