Closed Bug 1153908 Opened 5 years ago Closed 5 years ago

Move Tab Queue Notification click logic off UI thread

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 40
Tracking Status
firefox40 --- fixed
fennec 40+ ---

People

(Reporter: mhaigh, Assigned: mhaigh)

References

Details

Attachments

(1 file)

Currently we deal with the Tab Queue notification handling logic on the UI thread, but at some point we've added an assert to make sure we're not doing that on the UI thread as it involves opening and reading a file.  Offload this logic on to a background thread.
This adds a runnable to do file IO on a different thread, it also adds a runnable to do some View based work on the UI thread.
Attachment #8591748 - Flags: review?(michael.l.comella)
Attachment #8591748 - Flags: review?(michael.l.comella) → review+
Duplicate of this bug: 1154274
tracking-fennec: --- → ?
https://hg.mozilla.org/mozilla-central/rev/2057c753a9aa
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
tracking-fennec: ? → 40+
You need to log in before you can comment on or make changes to this bug.