[e10s] Get content process telemetry integrated and displaying

RESOLVED FIXED

Status

Webtools
Telemetry Dashboard
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

3 years ago
Content processes currently accumulate telemetry data and submit it (per bug 1024021) along with non-e01s telemetry data. This data currently isn't combined with and displayed with or split out from and displayed separately from existing non-e10s related telemetry data.

This bug is about getting the telemetry dashboard displaying this information for debugging purposes.

We anticipate e10s will start its roll out in Q2.
(Reporter)

Updated

3 years ago
Depends on: 1024021
It is pretty bad not having this, because for measurements like GHOST_WINDOWS or CC pause times we have zero visibility into what is happening for regressions, as far as I know.  So for instance, I can't use telemetry to try to figure out when bug 1158648 started.
Summary: Get content process telemetry integrated and displaying → [e10s] Get content process telemetry integrated and displaying
Vladan, what's the plan here?
Flags: needinfo?(vdjeric)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> Vladan, what's the plan here?

Georg is working on this in bug 1163971
Flags: needinfo?(vdjeric)
That bug sounds like it only covers about:telemetry. This bug is about telemetry.mozilla.org, which is much more important in my opinion. Right now, since most nightly users are on e10s, we don't have good telemetry coverage for new features that use histograms in the child process.
Oh I see, I skimmed the description and didn't notice this bug is talking about the dashboard. Our intern Anthony Zhang will soon begin working on the backend & frontend changes necessary to get count histograms, keyed histograms and e10s data displayed in the dashboard. As we're adding additional dimensions to the Telemetry data (channel + version + .. + e10s), we're bumping into the limits of the current Telemetry backend, so it's going to require some redesign, but I think we can get this done by July
(In reply to Andrew McCreight [:mccr8] from comment #1)
> It is pretty bad not having this, because for measurements like
> GHOST_WINDOWS or CC pause times we have zero visibility into what is
> happening for regressions, as far as I know.  So for instance, I can't use
> telemetry to try to figure out when bug 1158648 started.

We can do a custom telemetry analysis to fill the gap until the dashboard is ready, send me an email with the question you're trying to answer and we can send you the results or set up a daily .json report
This was fixed in the new Telemetry dash that Anthony Zhang wrote during his summer 2015 internship https://telemetry.mozilla.org/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
tracking-e10s: + → ---
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.