crash in mozilla::GonkVideoDecoderManager::codecReserved() - Performing FTU Tour results in Crash Report

VERIFIED FIXED

Status

()

Core
Audio/Video
--
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: oliverthor, Assigned: Silne30)

Tracking

({crash})

unspecified
ARM
Gonk (Firefox OS)
crash
Points:
---

Firefox Tracking Flags

(b2g-master fixed)

Details

(Whiteboard: [3.0-Daily-Testing], crash signature, URL)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-bccee81f-955d-496e-b3d7-d18532150413.
=============================================================

Description:
When the user flashes their phone and begins their FTU, they have the potential to see a crash report on their screen. When the entire FTU has been completed, the final options offers the user to see a tour of the phone. If the user concedes and performs the tour, after completing it they may encounter a crash report.

Repro Steps:
1) Flash phone to 20150413010203
2) Progress through to FTU until it offers a tour
3) Tap 'Next' to proceed through the tour
4) Tap 'Next' to progress through the tour until you reach the homescreen
5) Observe screen

Actual Results:
Encounter a crash report

Expected Results:
Encounter the homescreen


--------------------------------------------------
Environmental Variables:
Device: Flame 3.0
BuildID: 20150413010203
Gaia: 3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gecko: 0a46652bd992
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
--------------------------------------------------

Repro Rate: 6/8
Attachments:
will add video when it uploads
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
We've had a couple variations on this bug(1)(2) since introducing the video tour. The FTU app is the canary in the mine here - being the first time the media decoder gets put to use. 

https://bugzilla.mozilla.org/show_bug.cgi?id=1103926
https://bugzilla.mozilla.org/show_bug.cgi?id=1115241
https://bugzilla.mozilla.org/show_bug.cgi?id=1091500

These may be hardware & partner specific bugs. If you cant access them, let me know and I'll try and summarize.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Component: Gaia::First Time Experience → Video/Audio
Product: Firefox OS → Core
(Reporter)

Comment 2

3 years ago
YouTube has dropped arms and negotiated with my request to upload a video.

I don't have access to these other bugs you mention Sam, though not sure if your summary would be intended for me, since little action is required on blackbox to discover this issue and discriminate further where the problem originated.


Another detail that may appear interesting however, as displayed in the video, is the tour being skipped at each 'page' before being given a chance to load it's graphic. I have been UNABLE TO REPRO the issue by waiting for the graphic on each page.
(In reply to Oliver Nelson [:oliverthor] from comment #2)
> YouTube has dropped arms and negotiated with my request to upload a video.

Thanks for the video, so this reproduces on a Flame? I we may be looking at a regression in that case. I'm not able to reproduce here though, using a nightly PVT build on Flame, Gaia master. 
 
> Another detail that may appear interesting however, as displayed in the
> video, is the tour being skipped at each 'page' before being given a chance
> to load it's graphic. I have been UNABLE TO REPRO the issue by waiting for
> the graphic on each page.

I tried skipping through each step as fast as I could but still no crash. I wonder what the other variables are?
(Reporter)

Comment 4

3 years ago
I have been unable to reproduce this issue on 2.2 devices thus far, so a regression seems like a sure bet.  

One important factor that I'm noticing is missing from my original variables is that my device is on 319MB memory, almost exclusively day-to-day. I'll keep an eye out on that for future writings.
Hi Blake,
Can you take this bug or ask Alfredo for help?
Flags: needinfo?(bwu)
ayang, 
May I have your help? :)
Flags: needinfo?(bwu) → needinfo?(ayang)
I encountered this crash before and I think it won't happen after bug 1132832.
Please let me know if it's reproduced again.
Thank you.
Flags: needinfo?(ayang)
QAWanted to check a build with the patch for bug 1132832
Keywords: qawanted
(In reply to KTucker [:KTucker] from comment #8)
> QAWanted to check a build with the patch for bug 1132832
Need to include the patch in bug 1146729 as well.
(Assignee)

Updated

3 years ago
Assignee: nobody → jdorlus
I was unable to reproduce this issue on the original build so I cannot check it.  Leaving the qawanted tag so others can try.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150413010203
Gaia: 3c68964cb9fdba7cf0f6829b7f44562acaf1f1d7
Gecko: 0a46652bd992
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
Oliver can you reproduce this issue still?
Flags: needinfo?(onelson)
(Reporter)

Comment 12

3 years ago
Unable to reproduce this issue on latest master [3.0] for flame devices
Results: FTU Tour skips through without crash report

Environmental Variables:
Device: Flame 3.0
BuildID: 20150417010203
Gaia: 3cd0a9facce26c2acc7be3755a17131a6358e33f
Gecko: 51e3cb11a258
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
--------------------------------------------------

Repro Rate: 10/10 passing (crash was not encountered)
Flags: needinfo?(onelson) → needinfo?(pbylenga)
bug 1146729 looks like it had some issues landing but we're no longer reproducing so will close as Works-for-me.

NI on Blake in case something else is needed here to confirm.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(pbylenga) → needinfo?(bwu)
Keywords: qawanted
Resolution: --- → WORKSFORME
Hi Peter,
Thanks for this info. 
The patch in bug 1146729 is required to test this bug. When this bug is reported, that patch was not backed out. Could someone help test it? Or we can try to repro this issue when that patch is landed.
Flags: needinfo?(bwu)
I understand what you mean now, I added qawanted to bug 1146729 to try Comment 14 out.
(Reporter)

Comment 16

3 years ago
Verifying fix on 3.0 for flame devices following resolution of blocking bug 1146729:

Results: FTU Tour does not crash after skipping through tour quickly
Device: Flame 3.0
BuildID: 20150428010206
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro: 10/10 passing
Status: RESOLVED → VERIFIED
status-b2g-master: affected → fixed
Depends on: 1146729
Resolution: WORKSFORME → FIXED
(Reporter)

Updated

3 years ago
No longer depends on: 1146729
You need to log in before you can comment on or make changes to this bug.