Closed Bug 1154128 Opened 6 years ago Closed 6 years ago

Deduplicate TrackedOptimization constants

Categories

(Core :: Gecko Profiler, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1154115

People

(Reporter: shu, Unassigned)

Details

Attachments

(1 file)

Deduplicate TrackedOptimization constants and put them in a side table. Instead of emitting

attempts: [ { strategy: "FOO", outcome: "BAR" } ]

emit

attempts: [0,0]

with a side table

optimizationConstants: {
  strategies: [ "FOO" ],
  outcomes: [ "BAR" ]
};

This reclaims a 5%. Not spectacular, but still worth it.
Attachment #8592030 - Flags: review?(kvijayan)
Comment on attachment 8592030 [details] [diff] [review]
Deduplicate tracked optimization constants.

Review of attachment 8592030 [details] [diff] [review]:
-----------------------------------------------------------------

Looks reasonable.
Attachment #8592030 - Flags: review?(kvijayan) → review+
Folding this into bug 1154115, which has become a rewrite and this part is not worth the time to separate out.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1154115
You need to log in before you can comment on or make changes to this bug.