Closed Bug 1154177 Opened 6 years ago Closed 6 years ago

Intermittent test_objectStore_openKeyCursor.html | application timed out after 450.0 seconds with no output | application crashed [@ mozilla::CycleCollectedJSRuntime::FixWeakMappingGrayBits] | Assertion failure: !JS::IsIncrementalGCInProgress(mJSRuntime)

Categories

(Core :: XPCOM, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1054648

People

(Reporter: cbook, Unassigned)

References

()

Details

b2g_emulator_vm mozilla-inbound debug test mochitest-debug-11

https://treeherder.mozilla.org/logviewer.html#?job_id=8802343&repo=mozilla-inbound

22:20:38 INFO - DeviceRunner TEST-UNEXPECTED-FAIL | dom/indexedDB/test/test_objectStore_openKeyCursor.html | application timed out after 450.0 seconds with no output
22:20:38 WARNING - PROCESS-CRASH | dom/indexedDB/test/test_objectStore_openKeyCursor.html | application crashed [@ mozilla::CycleCollectedJSRuntime::FixWeakMappingGrayBits]
22:20:38 INFO - Crash dump filename: /tmp/tmpRSHYzp/05dd04bc-6d56-70ed-186fb8fc-65ac80ae.dmp
22:20:38 INFO - Operating system: Android
22:20:38 INFO - 0.0.0 Linux 2.6.29-g41a03df #22 Thu Jun 26 10:59:09 CST 2014 armv7l Android/full/generic:4.0.4.0.4.0.4/OPENMASTER/eng.cltbld.20150413.154404:eng/test-keys
22:20:38 INFO - CPU: arm
22:20:38 INFO - 0 CPUs
22:20:38 INFO - Crash reason: SIGSEGV
22:20:38 INFO - Crash address: 0x0
22:20:38 INFO - Thread 0 (crashed)
22:20:38 INFO - 0 libxul.so!mozilla::CycleCollectedJSRuntime::FixWeakMappingGrayBits [CycleCollectedJSRuntime.cpp:c80858490720 : 1012 + 0x2]
22:20:38 INFO - r4 = 0x000003f5 r5 = 0x00000000 r6 = 0x40297000 r7 = 0x00000000
22:20:38 INFO - r8 = 0x00000000 r9 = 0x00000001 r10 = 0x00000000 fp = 0x00000000
22:20:38 INFO - sp = 0xbed68970 lr = 0x40840a0f pc = 0x4084320a
22:20:38 INFO - Found by: given as instruction pointer in context
22:20:38 INFO - 1 libxul.so!nsCycleCollector::FixGrayBits [nsCycleCollector.cpp:c80858490720 : 3496 + 0x3]
22:20:38 INFO - r4 = 0x40297000 r5 = 0x00000000 r6 = 0x40297000 r7 = 0x00000000
22:20:38 INFO - r8 = 0x00000000 r9 = 0x00000001 r10 = 0x00000000 fp = 0x00000000
22:20:38 INFO - sp = 0xbed68990 pc = 0x40843fdd
22:20:38 INFO - Found by: call frame info
22:20:38 INFO - 2 libxul.so!nsCycleCollector::BeginCollection [nsCycleCollector.cpp:c80858490720 : 3771 + 0x9]
22:20:38 INFO - r4 = 0x40297080 r5 = 0x00000000 r6 = 0x40297000 r7 = 0x00000000
22:20:38 INFO - r8 = 0x00000000 r9 = 0x00000001 r10 = 0x00000000 fp = 0x00000000
22:20:38 INFO - sp = 0xbed689a8 pc = 0x4084ac59
22:20:38 INFO - Found by: call frame info
22:20:38 INFO - 3 libxul.so!nsCycleCollector::Collect [nsCycleCollector.cpp:c80858490720 : 3604 + 0x9]
22:20:38 INFO - r4 = 0x00000000 r5 = 0x00000001 r6 = 0x40297000 r7 = 0x00000000
22:20:38 INFO - r8 = 0xbed68a58 r9 = 0x00000001 r10 = 0x00000000 fp = 0x00000000
22:20:38 INFO - sp = 0xbed689f0 pc = 0x4084b3b9
22:20:38 INFO - Found by: call frame info
22:20:38 INFO - 4 libxul.so!nsCycleCollector_collectSlice [nsCycleCollector.cpp:c80858490720 : 4105 + 0x11]
22:20:38 INFO - r4 = 0x4023e1c0 r5 = 0xbed68a2c r6 = 0xbed68a58 r7 = 0x00000000
22:20:38 INFO - r8 = 0x42f474c0 r9 = 0xbed68ab8 r10 = 0xbed68b8f fp = 0x00000000
22:20:38 INFO - sp = 0xbed68a20 pc = 0x4084b895
22:20:38 INFO - Found by: call frame info
22:20:38 INFO - 5 libxul.so!nsJSContext::RunCycleCollectorSlice [nsJSEnvironment.cpp:c80858490720 : 1558 + 0xb]
22:20:38 INFO - r4 = 0x42f47a30 r5 = 0x42f479fc r6 = 0xbed68a58 r7 = 0xbed68a54
22:20:38 INFO - r8 = 0x42f474c0 r9 = 0xbed68ab8 r10 = 0xbed68b8f fp = 0x00000000
22:20:38 INFO - sp = 0xbed68a48 pc = 0x40f1c3c1
22:20:38 INFO - Found by: call frame info
22:20:38 INFO - 6 libxul.so!CCTimerFired [nsJSEnvironment.cpp:c80858490720 : 1894 + 0x3]
22:20:38 INFO - r4 = 0x00000007 r5 = 0x42f479fc r6 = 0x00000078 r7 = 0x00000001
22:20:38 INFO - r8 = 0x44cdd3d0 r9 = 0xbed68ab8 r10 = 0xbed68b8f fp = 0x00000000
22:20:38 INFO - sp = 0xbed68a90 pc = 0x40f1c873
22:20:38 INFO - Found by: call frame info
22:20:38 INFO - 7 libxul.so!nsTimerImpl::Fire [nsTimerImpl.cpp:c80858490720 : 

22:23:08 INFO - 04-14 05:12:46.110 F/MOZ_Assert( 812): Assertion failure: !JS::IsIncrementalGCInProgress(mJSRuntime) (Don't call FixWeakMappingGrayBits during a GC.), at ../../../gecko/xpcom/base/CycleCollectedJSRuntime.cpp:1013
Component: JavaScript Engine → XPCOM
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1054648
That said, holy massive spike batman.
Flags: needinfo?(continuation)
The current spike originated from fx-team. Working on bisecting it down.
Retriggers say it started on the push for bug 1137252.
https://treeherder.mozilla.org/#/jobs?repo=fx-team&revision=bbb1b526cb56

Will backout in a bit.
Blocks: 1137252
Flags: needinfo?(continuation)
Can't help but notice this being spammed all over the failing logs. No sign of them in green runs.

09:40:07  WARNING -  04-14 16:24:10.731 W/GeckoConsole(  723): [JavaScript Error: "Settings queue head blocked at {e6162004-8ded-4bb2-839e-97041f2bf1f7} for 50.739 secs, Settings API may be soft lockup. Lock from: SettingsServiceLock@jar:file:///system/b2g/omni.ja!/components/SettingsService.js:80:17
20 green retriggers on the inbound backout push. I think the cause of this spike is confirmed :)
You need to log in before you can comment on or make changes to this bug.