[RTL][Calendar]The "Offline calendar" is overlapped by the frame at edit event view.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: mmedeiros)

Tracking

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

Reporter

Description

4 years ago
Posted image edit_event.png
[1.Description]:
[RTL][v2.2 & v3.0][Calendar]The bottom of text "Offline calendar" is overlapped by the frame at edit event view.
See attachment:edit_event.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch Calendar.
3. Create a new a event.
4. Tap the event just created.
5. Tap Edit button at top right of the screen.
6. Observe the text "Offline calendar".

[3.Expected Result]: 
6. The text should be shown clearly and nothing should overlap.

[4.Actual Result]: 
6. The "Offline calendar" is overlapped by the frame.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.194002
Firmware Date          Tue Apr 14 19:40:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
QA Whiteboard: [rtl-impact]
I think this looks pretty bad since the words are cut-off on the bottom which makes reading confusing and sense might get lost - but will let triage team decide if we should block on this or not.
blocking-b2g: --- → 2.2?
Priority: -- → P2
Hi Jacob,
Could you help to find someone who can fix this issue?
Thanks!
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(jshen)
I'll investigate this. It might be a gecko regression but I hope it's just a CSS mistake.
Assignee: nobody → mmedeiros
Flags: needinfo?(jshen)
Comment on attachment 8593551 [details] [review]
[gaia] millermedeiros:1154633-cropped-calendar-name > mozilla-b2g:master

was able to fix the problem by changing a few CSS properties. Was caused mainly because wrapper have padding and overflow:hidden and element that contains the text didn't had enough height to fit whole text (was being cropped).
Attachment #8593551 - Flags: review?(gaye)
Comment on attachment 8593551 [details] [review]
[gaia] millermedeiros:1154633-cropped-calendar-name > mozilla-b2g:master

Stealing review as discussed in IRC since :gaye is unavailable at this time:

It looks like the `#modify-event-view .current-calendar input` created a box that would overlap the carat icon in the left corner of current-calendar (when in Arabic). So if the string in the input was longer, there would be overlap issues.

I just removed that whole style block and that worked fine. So it looks like for this patch that just this part is sufficient:

#modify-event-view .current-calendar .button {
  padding-top: 0;
  padding-bottom: 0;
}

I checked back in en-US and it looks correct too.

So if that change is done, r+ from me. If you feel like the other style block was needed for a case I did not try, we should talk more about it.
Attachment #8593551 - Flags: review?(gaye) → review+
landed on master: https://github.com/mozilla-b2g/gaia/commit/116e22f64fcc6cc58f9323ea234544b982156141
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8593551 [details] [review]
[gaia] millermedeiros:1154633-cropped-calendar-name > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): arabic language
[User impact] if declined: calendar name will be cropped on edit event view
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): very low (basic CSS changes)
[String changes made]: none
Attachment #8593551 - Flags: approval-gaia-v2.2?
Attachment #8593551 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Reporter

Comment 10

4 years ago
Posted image verified_pass.png
This issue has been verified passed on latest build of Flame 2.2/3.0 and Nexus 2.2/3.0 with the same steps in comment 0.
See attachment:verified_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150423162502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5fe76b26e55f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.195827
Firmware Date          Thu Apr 23 19:58:39 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.193607
Firmware Date          Thu Apr 23 19:36:18 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (pass)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.035409
Firmware Date          Thu Apr 23 03:54:27 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (pass)
Build ID               20150423160207
Gaia Revision          0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gaia Date              2015-04-23 16:10:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150423.192918
Firmware Date          Thu Apr 23 19:29:36 EDT 2015
Bootloader             HHZ12f
Reporter

Updated

4 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Reporter

Comment 11

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/16257/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.