[Flame][Wifi]It will not automatically connect to known network after WPS timed out.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
9 months ago

People

(Reporter: yue.zhou, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8592724 [details]
Bug log: logcat_914.txt

[1.Description]:
[Flame][v2.2&v3.0][Wifi]It will not automatically connect to known network after WPS timed out.
Attachments: logcat_914.txt, 914_1.mp4 and 914_2.mp4
Happen time: 9:14 AM

[2.Testing Steps]: 
1. Launch Settings
2. Tap Wi-Fi
3. Enable Wi-Fi and connect to a Wi-Fi AP
4. Tap Automatic Wi-Fi setup -> OK (Don't push WPS button on any Wi-Fi AP)
5. Wait for 2 mins to make it time out

[3.Expected Result]: 
5. It should automatically connect to known network after WPS timed out.

[4.Actual Result]: 
5. It will not automatically connect to known network.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.194002
Firmware Date          Tue Apr 14 19:40:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(gchang)
(Reporter)

Comment 1

4 years ago
Created attachment 8592725 [details]
Bug video part 1:: 914_1.mp4
(Reporter)

Comment 2

4 years ago
Created attachment 8592727 [details]
Bug video part 2: 914_2.mp4
Hi Vincent,
Not sure if this is by design. For the rest networks, if the connection failed, device will connect to other known network automatically.
Flags: needinfo?(gchang) → needinfo?(vchang)
I think it's by design in wpa_supplicant and our framework. But I think we could polish it a little bit.
Flags: needinfo?(vchang)

Comment 5

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.