bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 5693
17 years ago
17 years ago

People

(Reporter: tapio.markula, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I tried to create with dynamic pseudo-classes + IFRAME 
DOM2-styles sub-menus.

(Indeed my used Mozilla 0.9 is 5 month old)

The menu is visible ONLY in the state :hover => it can't be used:
see
http://www.nic.fi/~tapio1/Tests/Alivalikko.html

The system works in MS IE, because a:active works like a:focus.

See my basic principles:
http://www.nic.fi/~tapio1/Teaching/Muotoilut.php3#DHTML

Comment 1

17 years ago
Confirmed Fizzilla 0.9.6.

Mousing over the triangles next to "In English" and "HTML-Kit" produce scrolling
listbox elements which cannot be scrolled. Once the mouse leaves the gray
triangles, the menus disappear.

I was not, however, able to get this to work on IE6 Win at ALL. The entire top
menu thingy didn't show up.

And IE5 Mac generated the menus even without the triangles being hovered over.

Reporter, which version of MS IE did you get this to work in?
Status: UNCONFIRMED → NEW
Ever confirmed: true
The url has lots and lots of style sheets it loads.  Which sheet in particular 
has the CSS that's supposed to produce the effect in question?
Found the problem.

something:hover something { style }

requires the outer something to be in :hover when the mouse is over the inner 
something.

*** This bug has been marked as a duplicate of 5693 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.