Fix timings race in nsHttpTransaction

RESOLVED DUPLICATE of bug 1213699

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 1213699
3 years ago
2 years ago

People

(Reporter: valentin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

(Reporter)

Description

3 years ago
It is apparent from bug 1139831 and bug 1141370 that there is a race in nsHttpTransaction.
Under certain conditions it seems that the *start timestamp is set, but not the *end timestamp.

It is possible to mitigate the issue for resource timing, but we should still fix the underlying problem.
Whiteboard: [necko-backlog]
(Reporter)

Comment 1

2 years ago
Closing in favor of bug 1213699. It's the last racy timings bug left.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213699
You need to log in before you can comment on or make changes to this bug.