Use Socorro symbol api for uploading crash reporter symbols

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(firefox40 affected)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Currently we use scp to upload the symbols to the symbols server. 

From what I understand, Moco is moving away from ssh and using the
Socorro API to do this.  

What is needed:

1) The Socorro API token. (bug 1155011)
2) Modify our buildbot-configs 
3) Modify our puppet repo to support this.

(right now, only OSX64 is affected -- just pushed a temp workaround fix
 in bug 1155007)
Depends on: 1155011
OS: Windows 8.1 → All
Hardware: x86_64 → All
Assignee: nobody → ewong
Status: NEW → ASSIGNED
this is still blocked by bug 1155011.  Only when this bug is fixed can
this patch and others be applied to their respective repos.
Attachment #8599298 - Flags: review?(bugspam.Callek)
Attachment #8599298 - Attachment filename: bug_1155011_puppet.diff → bug_1155013_puppet.diff
I was just about to file this bug, glad to see you've already got patches! You'll also need a patch to add SOCORRO_SYMBOL_UPLOAD_TOKEN_FILE to your mozconfigs, like https://dxr.mozilla.org/mozilla-central/source/build/unix/mozconfig.linux#45 .
Blocks: 1071724
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #3)
> I was just about to file this bug, glad to see you've already got patches!
> You'll also need a patch to add SOCORRO_SYMBOL_UPLOAD_TOKEN_FILE to your
> mozconfigs, like
> https://dxr.mozilla.org/mozilla-central/source/build/unix/mozconfig.linux#45
> .

Thanks ted for the heads up there.
Have you generated the additional patches for the mozconfigs? Is it on a different bug?
Flags: needinfo?(ewong)
(In reply to Ian Neal from comment #5)
> Have you generated the additional patches for the mozconfigs? Is it on a
> different bug?

Nope. not yet. I'll be putting it on this bug.
Flags: needinfo?(ewong)
(In reply to Edmund Wong (:ewong) from comment #6)
> (In reply to Ian Neal from comment #5)
> > Have you generated the additional patches for the mozconfigs? Is it on a
> > different bug?
> 
> Nope. not yet. I'll be putting it on this bug.

Well, we either backout the patches from bug 1155007, or to make it less
complicated (procedure wise, since those patches are still waiting for
post-land review),  have the backout patches placed here.
Comment on attachment 8599298 [details] [diff] [review]
[puppet] changes to support the Socorro API token [checked-in]

Pushed to SeaMonkey/puppet:
  https://hg.mozilla.org/SeaMonkey/puppet/rev/c459343465f3
Comment on attachment 8599302 [details] [diff] [review]
[configs] changes to move the token to the mock environment. [checked-in]

Pushed to buildbot-configs:
https://hg.mozilla.org/build/buildbot-configs/rev/4a47aed6d4f7
Comment on attachment 8630856 [details] [diff] [review]
mozconfig nightly patches. (v1)

Note to self: There are more changes required for this patch.  Namely for the
Win32 one which requires adding mention to include build/mozconfig.win-common
(added to the tree via bug 1171218) in the win32
mozconfig.{nightly,release,debug} files.
Attachment #8599302 - Attachment description: buildbot config changes to move the token to the mock environment. → [configs] changes to move the token to the mock environment. [checked-in]
Attachment #8599298 - Attachment description: puppet changes to support the Socorro API token → [puppet] changes to support the Socorro API token [checked-in]
(In reply to Edmund Wong (:ewong) from comment #11)
> Comment on attachment 8630856 [details] [diff] [review]
> mozconfig nightly patches. (v1)
> 
> Note to self: There are more changes required for this patch.  Namely for the
> Win32 one which requires adding mention to include build/mozconfig.win-common
> (added to the tree via bug 1171218) in the win32
> mozconfig.{nightly,release,debug} files.

Addendum note: Since comment #11, these 'unset' mozconfigs had been uplifted to c-a and subsequently to c-b and c-r.  They all need to be backed out.
Comment on attachment 8630856 [details] [diff] [review]
mozconfig nightly patches. (v1)

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: symbols/packages are not uploaded
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: none
Attachment #8630856 - Flags: review?(kairo)
Attachment #8630856 - Flags: approval-comm-release?
Attachment #8630856 - Flags: approval-comm-beta?
Attachment #8630856 - Flags: approval-comm-aurora?
Blocks: 1155007
[Approval Request Comment]
Regression caused by (bug #): 1155007
User impact if declined:  no symbol uploads
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Attachment #8630856 - Attachment is obsolete: true
Attachment #8630856 - Flags: review?(kairo)
Attachment #8630856 - Flags: approval-comm-release?
Attachment #8630856 - Flags: approval-comm-beta?
Attachment #8630856 - Flags: approval-comm-aurora?
Attachment #8678404 - Flags: review?(kairo)
Attachment #8678404 - Flags: approval-comm-release?
Attachment #8678404 - Flags: approval-comm-beta?
Attachment #8678404 - Flags: approval-comm-aurora?
Comment on attachment 8678404 [details] [diff] [review]
[mozconfigs] remove unset lines in nightly mozconfigs.

Review of attachment 8678404 [details] [diff] [review]:
-----------------------------------------------------------------

r+a=me if it goes along with having an API token actually set in our build system and uploads working with that ;-)
Attachment #8678404 - Flags: review?(kairo)
Attachment #8678404 - Flags: review+
Attachment #8678404 - Flags: approval-comm-release?
Attachment #8678404 - Flags: approval-comm-release+
Attachment #8678404 - Flags: approval-comm-beta?
Attachment #8678404 - Flags: approval-comm-beta+
Attachment #8678404 - Flags: approval-comm-aurora?
Attachment #8678404 - Flags: approval-comm-aurora+
Comment on attachment 8599302 [details] [diff] [review]
[configs] changes to move the token to the mock environment. [checked-in]

As per Callek's approval on irc, I'm closing bugs that have patches which have been pushed already.
Attachment #8599302 - Flags: review?(bugspam.Callek)
we're using socorro now.  We just need to regularly update the api key.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Attachment #8599298 - Flags: review?(bugspam.Callek)
You need to log in before you can comment on or make changes to this bug.