[Music]Music app will not automatically switch to next song.

RESOLVED DUPLICATE of bug 1156519

Status

RESOLVED DUPLICATE of bug 1156519
4 years ago
4 years ago

People

(Reporter: huayu.li, Assigned: hub)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8593293 [details]
logcat00003.txt

[1.Description]:
[Nexus5 2.2&3.0][Flame 2.2&v3.0][Music]When playing a song, if you do not drag the seek bar to the end of progress bar, music app will not automatically switch to next song. Instead, it is paused when a song is over.
Found at:14:40
see attachments:2015-04-16-14-59-50.png,logcat00003.txt
[2.Testing Steps]: 
1.Open the music app.
2.Choose the songs model.
3.Click a song to paly.
4.Don't unlock the phone, waiting for  the song completed

[3.Expected Result]: 
4.When the playing song is over, it will play the next song.

[4.Actual Result]: 
5.The music is paused.

[5.Reproduction build]:
Device: Flame 2.2[Affected]
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.201243
Firmware Date          Wed Apr 15 20:12:52 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0[Affected]
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150415.192055
Firmware Date          Wed Apr 15 19:21:04 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2[Affected]
Build ID               20150415162504
Gaia Revision          89a94a8b9c9087da916751697a61ba15bc0688c3
Gaia Date              2015-04-15 20:05:38
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20e92b626530
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150415.200855
Firmware Date          Wed Apr 15 20:09:09 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0[Affected]
Build ID               20150415160205
Gaia Revision          777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gaia Date              2015-04-15 17:20:09
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/53ceefb0e1c8
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150415.192113
Firmware Date          Wed Apr 15 19:21:33 EDT 2015
Bootloader             HHZ12f


[6.Reproduction Frequency]: 
occasionally Recurrence,8/10

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8593294 [details]
2015-04-16-14-59-50.png
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
[Blocking Requested - why for this release]: broken functionality, regression.
blocking-b2g: --- → 2.2?
status-b2g-v2.1: --- → unaffected
Keywords: regression
Keywords: regressionwindow-wanted
(Assignee)

Comment 3

4 years ago
I'm pretty sure it is revision 00130552f1913dab822762ba85d47ba2825bf80e of gaia that caused it (on master) and since the change has been uplifted to 2.2.


Will look at it.
Assignee: nobody → hub
Status: NEW → ASSIGNED
(Assignee)

Comment 4

4 years ago
Caused by Bug 1145758  that is.
Cause already identified at comment 4.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
(Assignee)

Comment 6

4 years ago
I can't seem to be able to reproduce this on Flame on a current master.
(Assignee)

Comment 7

4 years ago
Nor can I on gaia 777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Adding qawanted to see if we can still reproduce this on master.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: jmercado
I am still able to reproduce this issue on the latest Nightly 3.0 and 2.2 builds.

Actual Results: The song player does not finish the current song and move to the next.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150417010203
Gaia: 3cd0a9facce26c2acc7be3755a17131a6358e33f
Gecko: 51e3cb11a258
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150417002504
Gaia: d50b8a3919a7b4d8d289f150d3b9bed704ebafa9
Gecko: 5ebf32030512
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Blocking Reason: regression
blocking-b2g: 2.2? → 2.2+
Bug 1156519 may be the same bug as this one.  I'll work on it in that other bug.
I think I understand what is going on here: https://bugzilla.mozilla.org/show_bug.cgi?id=1156519#c8
Flags: needinfo?(hub)
This is a dupe of bug 1156519, and will be resolved when we back out bug 1145758
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1156519
(Assignee)

Updated

4 years ago
Flags: needinfo?(hub)
You need to log in before you can comment on or make changes to this bug.