CDM fails to play under some conditions

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
P2
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: adalucinet, Unassigned)

Tracking

(Blocks: 2 bugs)

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

3 years ago
Reproducible on latest Developer Edition 39.0a2 (Build ID: 20150415004020) and latest Nightly 40.0a1 (Build ID: 20150415030206)
Affected platform: Windows 7 64-bit

Steps to reproduce:
1. Wait for CDM (version 8) to download via Add-ons Manager/Plugins.
2. Play http://drmtest2.adobe.com/HTML5AAXSPlayer/2/mse-access/ video.

Notes:
1. After I hit Play button, the following lines are displayed below the video area:
MediaKeys.isTypeSupported not defined, we'll use navigator.requestMediaKeySystemAccess
EVENT: loadstart
sourceopen
EVENT: progress
EVENT: loadedmetadata
EVENT: encrypted
video got encrypted event
created MediaKeys object ok
video ensured MediaKeys available on HTMLMediaElement
video generated request
EVENT: progress
All segments downloaded
EVENT keymessage received eventType = license-request
license request: destinationURL = http://drmtest2.adobe.com:8080/flashaccess/req
EVENT error session=5998329224716694817 systemCode=3328 err=[object MediaKeyError]
EVENT: stalled
2. Encountered the same result after deleting %appdata%\Mozilla\Firefox\Profiles\$profile\gmp\storage and all data about CDM ("Forget this site" option).
3. Same results with versions 6 and 7 of CDM.
4. Browser console output: AccessGMP: DRM Error 3328 DRM Minor Error 1000559
5. Couldn't reproduce on a different Windows 7 64 bit machine nor on Windows 8.1 32 bit.
Blocks: 1032660, 1015800
Priority: -- → P2
Alexandra: A few questions:

* What video cards are in both of your Win7 machines, the one that works and the one that does not? Are they both the same? It's possible that your graphics card can't handle output on the RGB monitor.
* What versions of Win7 are on these machines? Is it Enterprise Windows, Pro? Home Premium etc?
* Are there any Firefox addons installed on these machines, and is there any difference in addons installed on these machines?
* Are there any Firewalls or AntiVirus software installed on these machines?
Flags: needinfo?(alexandra.lucinet)
Also:
* What service pack(s) does the failing Win7 machine have installed, if any?

FYI, minor code 1000559 is an "invalid license" error code. So that's why I'm curious about firewalls/antivirus, as the license response could be being messed with.
(Reporter)

Comment 3

3 years ago
(In reply to Chris Pearce (:cpearce) from comment #1)
> * What video cards are in both of your Win7 machines, the one that works and
> the one that does not? Are they both the same? It's possible that your
> graphics card can't handle output on the RGB monitor.
* The one that works: AMD Radeon HD 6450
* The one that doesn't work: NVIDIA GeForce 210

> * What versions of Win7 are on these machines? Is it Enterprise Windows,
> Pro? Home Premium etc?
Both machines have Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.150316-1654)

> * Are there any Firefox addons installed on these machines, and is there any
> difference in addons installed on these machines?
All testing was performed with a clean profile.

> * Are there any Firewalls or AntiVirus software installed on these machines?
Yes, AVG AntiVirus Business Edition 2013 is installed on both machines.
Flags: needinfo?(alexandra.lucinet)
Alexandra, do you still get this error on that Win7 machine in Firefox Nightly?
Flags: needinfo?(alexandra.lucinet)
(Reporter)

Comment 5

2 years ago
(In reply to Chris Pearce (:cpearce) from comment #4)
> Alexandra, do you still get this error on that Win7 machine in Firefox
> Nightly?

No, I'm unable to reproduce with latest 41.0a1 (from 2015-05-26).
Flags: needinfo?(alexandra.lucinet)
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #5)
> (In reply to Chris Pearce (:cpearce) from comment #4)
> > Alexandra, do you still get this error on that Win7 machine in Firefox
> > Nightly?
> 
> No, I'm unable to reproduce with latest 41.0a1 (from 2015-05-26).

Assuming it's fixed then.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.