Closed Bug 1155187 Opened 5 years ago Closed 4 years ago

Out of memory with Jenga webgl game

Categories

(Core :: Canvas: WebGL, defect)

37 Branch
x86
Windows 8.1
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: VarCat, Unassigned)

References

()

Details

Environment:

FF 37.0.2
Build Id: 20150415140819
Graphics: AMD Radeon HD 5450
OS: Win 8.1 x86

STR:

1. Open http://chandlerprall.github.io/Physijs/examples/jenga.html
2. Try dragging on of the Jenga pieces.

Issues:
Cannot interact with the jenga pieces.

Note:
This issues is reproducible only on this environment.
In browser console the following error is displayed:
InternalError: uncaught exception: out of memory <unknown>
Summary: Cannot interact with the jenga pieces on http://chandlerprall.github.io/Physijs/examples/jenga.html webgl game → Out of memory with Jenga webgl game
Catalin, can you please check if other browsers (eg. Chrome, IE, Safari) display this problem on your system?
Graphics section of about:support would be most useful.  Also, if you set environment variable MOZ_GL_SPEW to 1 and run again, any additional messages?
I've test this using Chrome and the same issue is reproducible on chrome.(Uncaught RangeError: Invalid array buffer length - error is displayed in Javascript console)
On IE the performance is extremely bad as in 7 FPS.
However on Opera it works just fine.

I've used MOZ_GL_SPEW = 1 as environment variable but the same issue was present.

The bug is reproducible on FF 39, FF 40.0b7 but is not reproducible on the latest FF42 Nightly.

Graphics
Adapter Description	AMD Radeon HD 5450
Adapter Drivers	aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Adapter RAM	1024
Asynchronous Pan/Zoom	none
Device ID	0x68f9
Direct2D Enabled	true
DirectWrite Enabled	true (6.3.9600.17795)
Driver Date	12-6-2013
Driver Version	13.251.0.0
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	00000000
Supports Hardware H264 Decoding	true
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon HD 5450 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Thanks for the test results Catalin. Based on this I'm not sure we need to worry about this on our end. It looks like things may be fine once 42 makes is way along the trains. We might want to reach out to the developer to let them know but I'm not sure there's something we need to fix on our end.

Any differing opinions?
Actually, just another thought: it might be worth finding a range for when this problem went away in Firefox. If there's something we landed in 42 that makes this go away and it's low enough risk it might be worth nominating it to uplift.
Closing this bug since there were no objections to my earlier comments.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.