Closed Bug 115544 Opened 23 years ago Closed 23 years ago

width="..%" generates wrong width

Categories

(Core :: Layout, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 97695

People

(Reporter: forum.mick, Assigned: attinasi)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

I have a page and I want to place 15 buttons beside each other and I determine
there width with %. I want to do this so everybody sees all the buttons and
there will be no problem. When I give each button a width="10%" I want that
there will be a line of 10 buttons with a tenth of the framesize and another
line with 5 buttons of the same size.

The problem is that the first button is realy 10% of framesize but the second
button is 10% of 90%. This means that the second button is 10% of the remaining
space. The line buttons will be displayed on one line and the buttons will be
smaller and smaller.

In internet explorer it is displayed as it should be. I also tried to use the
standard layout mode and the quicks one, but it doesn't seem to matter.


Reproducible: Always

Steps to Reproduce:
1. Watch my site http://compower.xs4all.nl/vrienden/profiles.html


Actual Results:  See discription

Expected Results:  See discription
Duplicate of "Images with %sizes inside links should scale relative to 
containing block"

*** This bug has been marked as a duplicate of 97695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.