Black embedded YouTube video

RESOLVED FIXED in Firefox 38

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dabixili, Assigned: mattwoodrow)

Tracking

(Blocks 1 bug)

39 Branch
mozilla40
x86_64
Other
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox38+ fixed, firefox39+ fixed, firefox38.0.5 fixed, firefox40 fixed, firefox-esr38 fixed)

Details

()

Attachments

(2 attachments)

Reporter

Description

4 years ago
Gfx info from about:support:
> Adapter Description: Intel(R) G45/G43 Express Chipset
> Direct2D: true
> DirectWrite: true
> Driver: igdumd64 igd10umd64 igdumdx32 igd10umd32
> Accel. Windows: 4/4 Direct3D 11 (OMTC)
> Driver Version: 8.15.10.2869
> Device ID: 0x2e22
> Vendor ID: 0x8086
> Subsystem ID: 024c1025
> AzureCanvasBackend: direct2d 1.1
> AzureContentBackend: direct2d 1.1
> AzureFallbackCanvasBackend: cairo
Reporter

Updated

4 years ago
Blocks: MSE
Reporter

Comment 1

4 years ago
Video stats:
> Dimensions: 689 x 388 * 1
> Resolution: 426 x 240@30
> Stream Type: https
> Mime Type: video/mp4; codecs="avc1.4d4015"
> DASH: yes (133/140)
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #2)
> Try http://people.mozilla.org/~mwoodrow/sanity-test.xpi and paste in the
> result.

Sctatch that - look at http://people.mozilla.org/~ajones/blank-video/ and tell if if you see two white/green/blue/red squares with the top one at a 45 degree angle.
Reporter

Comment 4

4 years ago
I see only one square. I don't see the top one.
Reporter

Comment 5

4 years ago
Posted image screenshot.png
This is a driver bug to the best path forward is to update the driver. Alternatively you can disable acceleration from about:preferences#advanced by unchecking "Use hardware acceleration when available" but this will make things go slower. We are working on a mechanism to automatically detect this kind of bug.
Assignee

Comment 7

4 years ago
Posted patch blacklistSplinter Review
Approval Request Comment
[Feature/regressing bug #]: HTML5 Video
[User impact if declined]: Black video
[Describe test coverage new/current, TreeHerder]: None
[Risks and why]: Simple blacklist addition
[String/UUID change made/needed]: None
Assignee: nobody → matt.woodrow
Attachment #8599547 - Flags: review?(ajones)
Attachment #8599547 - Flags: approval-mozilla-beta?
Attachment #8599547 - Flags: approval-mozilla-aurora?
Assignee

Comment 8

4 years ago
[Tracking Requested - why for this release]:
Attachment #8599547 - Flags: review?(ajones) → review+
Comment on attachment 8599547 [details] [diff] [review]
blacklist

[Triage Comment]
taking it now to be sure it makes 38.0 RC1
Attachment #8599547 - Flags: approval-mozilla-release+
Attachment #8599547 - Flags: approval-mozilla-beta?
Attachment #8599547 - Flags: approval-mozilla-aurora?
Attachment #8599547 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/84114ca615db
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Reporter

Comment 16

4 years ago
> This is a driver bug to the best path forward is to update the driver.

Unfortunately there's no driver update available for this graphics card. The latest version is the one I'm using: 15.17.19.64.2869 (8.15.10.2869).
Reporter

Comment 17

4 years ago
I can see the top square at http://people.mozilla.org/~ajones/blank-video/ when disabling hardware acceleration, but I still can't see the video at http://www.playboy.com/videos/handjob-karaoke-japan (but I can see it on another computer with Linux).

(Note that I have to manually disable HW acceleration, probably because the fix hasn't been released yet?)
Reporter

Comment 18

4 years ago
I can still reproduce this issue.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Reporter

Updated

4 years ago
See Also: → 1153123
(In reply to DaBiXILI from comment #18)
> I can still reproduce this issue.

Strange. Can you paste the commit URL from the Source section of about:buildconfig ?
Reporter

Comment 20

4 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #19)
> Strange. Can you paste the commit URL from the Source section of
> about:buildconfig ?

https://hg.mozilla.org/releases/mozilla-aurora/rev/44698a75f0a6 (it's newer than https://hg.mozilla.org/releases/mozilla-aurora/rev/536e415933af).
Reporter

Comment 21

4 years ago
I've just tested it on Nightly, and I can't see the video on Nightly as well.
about:support on Nightly says:
> Supports Hardware H264 Decoding	false
(In reply to DaBiXILI from comment #21)
> I've just tested it on Nightly, and I can't see the video on Nightly as well.
> about:support on Nightly says:
> > Supports Hardware H264 Decoding	false

Do you still get the same thing from http://people.mozilla.org/~ajones/blank-video/ ?
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #22)
> Do you still get the same thing from
> http://people.mozilla.org/~ajones/blank-video/ ?

You answered that in c17. Do you get audio on the embed? Can you see the video on https://www.youtube.com/watch?v=S47M8eX_eFc ?
Reporter

Comment 24

4 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #23)
> (In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #22)
> > Do you still get the same thing from
> > http://people.mozilla.org/~ajones/blank-video/ ?
> 
> Do you get audio on the embed?

I can hear audio on http://www.playboy.com/videos/handjob-karaoke-japan.

> Can you see the video on https://www.youtube.com/watch?v=S47M8eX_eFc ?

No, but I can hear the audio here as well.
Reporter

Comment 25

4 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #23)
> You answered that in c17.

To make it clearer, I can see the top square only if I entirely disable hardware acceleration from about:config. I can't see it normally, even if my driver is blacklisted for hardware video decoding.
(In reply to DaBiXILI from comment #25)
> (In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #23)
> > You answered that in c17.
> 
> To make it clearer, I can see the top square only if I entirely disable
> hardware acceleration from about:config. I can't see it normally, even if my
> driver is blacklisted for hardware video decoding.

We've put it down to being an issue with upload on this video card. The plan is to reproduce the test you're doing using js in bug 1156135.
Does bug 1153123 fix this?
Flags: needinfo?(dabixili)
While I'm tracking this for 39, it's marked fixed for 39. So I only came across it by chance. 
Is this problem still showing up?
Does bug 1156135 fix this issue?
OS: Windows 7 → Other
I'm going to mark this as fixed. Re-open if there it is still an issue.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Reporter

Comment 31

4 years ago
It's fixed in Firefox 41.
I can see the two squares on http://people.mozilla.org/~ajones/blank-video/.
The video on http://www.playboy.com/videos/handjob-karaoke-japan is using flash now, so I can't test it.

The flags probably need to be updated to reflect that this is broken on Firefox 39 (and probably Firefox 40).
Flags: needinfo?(dabixili)
You need to log in before you can comment on or make changes to this bug.