[System] "TypeError: slot.simCard.iccInfo is null" when booting my Flame

RESOLVED FIXED in 2.2 S11 (1may)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: julienw, Assigned: arthurcc)

Tracking

unspecified
2.2 S11 (1may)
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

I see this error when booting my Flame with 2 SIMs inside:

04-17 18:36:19.900 19293 19293 W GeckoConsole: [JavaScript Error: "TypeError: slot.simCard.iccInfo is null" {file: "app://system.gaiamobile.org/js/operator_variant_manager.js" line: 60}]

I don't know if there is any user-facing issue but at least this prevents subsequent code from running, which could be bad.
Arthur, any ideas?
Flags: needinfo?(arthur.chen)
Although I'm not able to reproduce it but it seems a racing. The iccinfo may not ready upon the starting up. I'll provide a patch later.
Flags: needinfo?(arthur.chen)
Comment on attachment 8595719 [details] [review]
[gaia] crh0716:1155748 > mozilla-b2g:master

Alive, in this patch I added an additional handler on simslot-iccinfochange so that we can run the operator variant handler at the correct time. A check on iccInfo was also added. The logic of the checks and operator variant handler creation was moved to a separate function to avoid code duplication. Would you mind take a look at it when you get a chance? Thanks.
Attachment #8595719 - Flags: review?(alive)
Julien, could you try whether the patch fixes the issue? Thanks.
Assignee: nobody → arthur.chen
Flags: needinfo?(felash)
Comment on attachment 8595719 [details] [review]
[gaia] crh0716:1155748 > mozilla-b2g:master

Thanks!
Attachment #8595719 - Flags: review?(alive) → review+
Actually it's difficult to say, I don't see this everytime I boot the Flame (actually quite rarely). So I can't check for sure this fixes the issue (but I think it does).

Also I'm not sure how I could check that everything still works as expected, but I applied the patch and used the phone simply and it seems to work fine. I'll assume alive knows better about it :)
Flags: needinfo?(felash)
Indeed, it is a racing and might be difficult to reproduce. Let's commit the code first and reopen the bug if it occurs again.
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8595719 [details] [review]
[gaia] crh0716:1155748 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: The possibility is low but once happened the operator variant settings may not be applied correctly.
[Testing completed]: Unit test added. Testing on the device ok but note that the the original reproduce rate is pretty low.  
[Risk to taking this patch] (and alternatives if risky): Low. It fixes a racing by listening to events from gecko.
[String changes made]: None
Attachment #8595719 - Flags: approval-gaia-v2.2?
Attachment #8595719 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.