Ctrl+e is consumed by Edit button and cursor doesn't move to the end of the line.

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
User Interface: Modal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: arai, Assigned: glob)

Tracking

Production
x86
Mac OS X

Details

(Reporter)

Description

3 years ago
On OS X, ctrl+e is the shortcut to move the cursor to the end of the line in textbox.

Steps to Reproduce:
  1. turn "Use experimental user interface" on
  2. open some bug (or this bug)
  3. focus on the "Add Comment" box
  4. type "hello"
  5. press Ctrl+a
  6. press Ctrl+e

Expected result:
cursor moves to the beginning of the line on step 5, and to the end of the line on step 6.

Actual result:
cursor moves to the beginning of the line on step 5, and edit fields opens on step6, and cursor stays at the beginning of the line. also, the comment box scrolls out of screen because edit fields expands.

If I press ctrl+e again, cursor moves to the end of the line.
(Assignee)

Updated

3 years ago
Assignee: nobody → glob
(Assignee)

Comment 1

3 years ago
i thought about finding a combo that doesn't conflict, or making ctrl+e windows only, but i ended up disabling the edit shortcut if an input field has focus.  this ensures we'll never conflict with whatever the text editor provides, and means we don't need platform specific checks (which sounds like a rabbit hole to me).

To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   a6f7795..5fef5fc  master -> master
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.