Closed Bug 115603 Opened 23 years ago Closed 23 years ago

DNS servers seem to be cached

Categories

(Core :: Networking, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 64857

People

(Reporter: hugoh, Assigned: gordon)

Details

(Keywords: qawanted)

If I launch Mozilla on my laptop and use it with my home ISP, and then connect to another ISP later on, it stops resolving host names.
It looks like the name servers are cached, and if for some reasons they become unreachable (e.g. change of ISP), name resolution stops working. I have seen this happening in every version of Mozilla under Linux.
Regards,
Hugo

*** This bug has been marked as a duplicate of 26718 ***
Status: UNCONFIRMED → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
-> networking, qa to me.
Status: RESOLVED → UNCONFIRMED
Component: Networking: Cache → Networking
QA Contact: tever → benc
Resolution: DUPLICATE → ---
I need to confirm one aspect:

After DNS goes deaf, can you still use IP addresses?

http://207.200.81.215/ is the IP address for mozilla.org's web site. Can you try
that?


*** This bug has been marked as a duplicate of 64857 ***
Status: UNCONFIRMED → RESOLVED
Closed: 23 years ago23 years ago
Resolution: --- → DUPLICATE
+qawanted
hugo:

also, we'd like to know if you can confirm that your home ISP DNS servers are 
not visible to you on the second ISP.

Keywords: qawanted
I changed the name server in resolv.conf, the previous ones were still
reachable, and Mozilla continued to happily let me browse the Web.

I also confirmed that, at least in one of the cases I experienced the problem,
the name servers that I had used previously were unreachable from my new location.

I haven't had a chance to check that 0.9.9 still has this problem.

Regards,

Hugo
You need to log in before you can comment on or make changes to this bug.