Dropdowns misbehave in e10s mode

RESOLVED DUPLICATE of bug 1152585

Status

()

defect
RESOLVED DUPLICATE of bug 1152585
4 years ago
4 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

(Blocks 1 bug, {reproducible})

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 affected)

Details

Reporter

Description

4 years ago
Perhaps related to Bug 910023 or Bug 1127029. Clicking select dropdowns with a tap works as expected. When actually pressing the touchpad button, the select is typically expanded and selected immediately. After selection the field remains selected (complete with blue ring). Clicking on a different element can expand the selected one!

This is eminently reproducible on Bugzilla. Using a non-e10s window makes the problem go away.

I'm uploading a video to YouTube now.

This might require a Force Touch capable MBP to repro; I switched machines and upgraded to Yosemite at the same time, which was about the time I got bumped to e10s, so apologies for not having clearer prerequisites.
Reporter

Comment 2

4 years ago
Turn the sound up to hear the difference between 'tap' and 'click', by the way.
Reporter

Updated

4 years ago
Blocks: e10s-select
thanks for filing with the video!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1049285
Since the list is expanding in the downward direction in the video, I actually suspect this is a dupe of bug 1152585.
Duplicate of bug: 1152585
You need to log in before you can comment on or make changes to this bug.