[NFC] The screen will become black, if you touch other place of the screen.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: wangxiaomei, Assigned: tauzen)

Tracking

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [v2.2-nexus-5-l])

Attachments

(3 attachments)

Reporter

Description

4 years ago
Posted file logcat_2255.txt
[1.Description]:
[Nexus5 2.2 & 3.0][Flame 2.2 & 3.0][NFC] Launch NFC app. Open gallery and select one picture to send. Put two devices back to back. If you touch other places exept picture, the screen of the test device will become black.
Time: 22:55
See attachment logcat_2255.txt and 2255.mp4

[2.Testing Steps]: 
1.Launch settings app and turn on NFC.
2.Launch gallery app and select one picture to open.
3.Put two devices back to back.
4.Touch other places except picture.
[3.Expected Result]: 
4.It has no reaction.

[4.Actual Result]: 
4. The screen  of test device becomes black.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.040848
Firmware Date          Sun Apr 19 04:08:59 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150419.193329
Firmware Date          Sun Apr 19 19:33:40 EDT 2015
Bootloader             L1TC000118D0


N5 2.2 version(Affected):
Build ID               20150419002502
Gaia Revision          c15a2b6d3a783813959c2b3bffd2a131f4270b9e
Gaia Date              2015-04-17 17:49:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cc02ee38b252
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150419.041307
Firmware Date          Sun Apr 19 04:13:23 EDT 2015
Bootloader             HHZ12f


N5 3.0 version(Affected):
Build ID               20150419160202
Gaia Revision          c6b04efa0f31a584e6ee0a46dd2b64c1e3c29adc
Gaia Date              2015-04-17 21:10:53
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a32e3b93c8d8
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150419.193737
Firmware Date          Sun Apr 19 19:37:53 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
occasionally Recurrence,5/10

[7.TCID]: 
Free Test
Reporter

Updated

4 years ago
Reporter

Comment 1

4 years ago
Posted video 2255.mp4
Flags: needinfo?(ashiue)

Comment 2

4 years ago
Flame 2.2 also can reproduce this issue.
Hi Alive, could you please check this issue? Thank you.
QA Whiteboard: [COM=NFC]
Flags: needinfo?(ashiue) → needinfo?(alive)
Could you take a look?
Flags: needinfo?(alive) → needinfo?(gduan)
:tauzen welcome to steal.
Flags: needinfo?(kmioduszewski)
Ok, I'm stealing this :).

So this caused by edge gesture detection. I can reproduce it each time i try to swipe horizontally when shrinking UI is visible. We should disable edge gesture detection while shrinking UI is visible.
Assignee: nobody → kmioduszewski
Flags: needinfo?(kmioduszewski)
Flags: needinfo?(gduan)
Comment on attachment 8595200 [details] [review]
[gaia] tauzen:Bug1156203_egde_gesture_disable > mozilla-b2g:master

Hi Alive, could you review this? I'm following the pattern used in rocketbar case, so this is just a small patch. 

Tested on both Flame and Nexus 5 master, works ok for me.
Attachment #8595200 - Flags: review?(alive)
Comment on attachment 8595200 [details] [review]
[gaia] tauzen:Bug1156203_egde_gesture_disable > mozilla-b2g:master

Hmm...I wonder why we don't check this before.
Attachment #8595200 - Flags: review?(alive) → review+
I guess it's almost impossible to encounter this bug in regular NFC usage. Shrinking UI displays 'swipe to share' text with arrow pointing up, it's really an edge case scenario.
Blocks: NFC-Gaia
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8595200 [details] [review]
[gaia] tauzen:Bug1156203_egde_gesture_disable > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined:
This is an edge case scenario which occurs when user swipes ShrinkingUI horizontally and triggers edge gesture detection. Poor user experience.
[Testing completed]: on device testing completed (Flame)
[Risk to taking this patch] (and alternatives if risky): 
Small patch to system/edge_swipe_detector.js - overall small risk.
[String changes made]: none
Attachment #8595200 - Flags: approval-gaia-v2.2?
blocking-b2g: --- → 2.2+
Attachment #8595200 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 13

4 years ago
Verified on 

[2.2]
Build ID               20150426162504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.200210
Firmware Date          Sun Apr 26 20:02:21 EDT 2015
Bootloader             L1TC100118D0

[3.0]
Build ID               20150426160201
Gaia Revision          b4c949cdc780893897c9b45c1adea46e2eb694ff
Gaia Date              2015-04-24 16:13:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d60e3b8be6
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.193323
Firmware Date          Sun Apr 26 19:33:34 EDT 2015
Bootloader             L1TC100118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.