If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

OpenH264: crash [@WelsDec::WelsCalcDeqCoeffScalingList]

RESOLVED FIXED

Status

External Software Affecting Firefox
OpenH264
--
critical
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: posidron, Unassigned)

Tracking

(Blocks: 2 bugs, {crash, testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8594829 [details]
testcase.264

Tested with https://github.com/cisco/openh264/commit/864ff21021
(Reporter)

Comment 1

3 years ago
Created attachment 8594830 [details]
callstack

Comment 2

3 years ago
I just replicated this crash with the master branch, but I cannot replicate it with the v1.4-Firefox38 branch (gives a 'Feature not supported' message).   So we need to fix this before the next version, but this shouldn't hold up the v1.4 rollout.

Comment 3

3 years ago
yes in 1.4 we disabled the recently-built high-profile support in 1.4.

Comment 4

3 years ago
This problem has been fixed in commit dac1363. The high-profile has been supported in master branch now.

Updated

2 years ago
Component: WebRTC: Audio/Video → OpenH264
Product: Core → Plugins

Updated

2 years ago
Depends on: 1170319

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.