Closed Bug 1156588 Opened 5 years ago Closed 2 years ago

"ASSERTION: not in child list" with grid, white-space:pre

Categories

(Core :: Layout, defect, minor)

defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox40 --- affected

People

(Reporter: jruderman, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: assertion, testcase, Whiteboard: [false positive])

Attachments

(2 files)

Attached file testcase
With:
  user_pref("layout.css.grid.enabled", true);

###!!! ASSERTION: not in child list: 'found', file layout/base/nsLayoutUtils.cpp, line 1231
Attached file stack
This verification DEBUG code is a bit out-of-date now that
nsInlineFram::Insert/Append/RemoveFrame deals with being called
on the wrong parent.
http://mxr.mozilla.org/mozilla-central/source/layout/base/nsLayoutUtils.cpp?rev=023fdd5ebd3f#1212

It's unrelated to Grid, but probably easier to reproduce there
since it doesn't handle incomplete children yet, so it's easy
to trigger OverflowLists laying around.

If someone wants to take a stab at fixing this: add a loop at the
end of this DEBUG block that also checks the GetNextInFlow chain
of 'parent' (if it's an nsInlineFrame).
Severity: normal → minor
OS: Mac OS X → All
Hardware: x86_64 → All
Whiteboard: [false positive]
The attached testcase no longer asserts. Leaving the bug open per comment 2, however.
Flags: in-testsuite+
Keywords: leave-open
Mats, is comment 2 still valid?
Flags: needinfo?(mats)
Yeah, it was probably a false positive, but I'm fine leaving the assertion as is.
I'll investigate again if we get another testcase that triggers it...
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mats)
Resolution: --- → WORKSFORME
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.