Closed Bug 1156606 Opened 5 years ago Closed 5 years ago

Use WheelScrollAnimation for instant scrolling, too

Categories

(Core :: Panning and Zooming, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dvander, Assigned: dvander)

References

Details

Attachments

(1 file)

ESM uses its async scroll animation for instant scrolling, too - it just moves to the destination in one frame, skipping the timing function. This is easy enough to do in APZ and gets rid of a bunch of code.

The motivation for this was that using pan-gestures can leave the last repaint request stuck in the throttling queue, which led to intermittent timeouts on some mochitests. I can't reproduce that with this patch, but I'm not sure if this actually guarantees it's fixed.

Either way I'm happy to not rely on the panning code for wheel scrolling.
Attached patch patchSplinter Review
Attachment #8595125 - Flags: review?(bugmail.mozilla)
Comment on attachment 8595125 [details] [diff] [review]
patch

This caused another test to start failing... clearing review for now.
Attachment #8595125 - Flags: review?(bugmail.mozilla)
FWIW I do like the simplification in this patch, and the removal of the pangesture events.
(In reply to David Anderson [:dvander] from comment #2)
> Comment on attachment 8595125 [details] [diff] [review]
> patch
> 
> This caused another test to start failing... clearing review for now.

Do you happen to recall which test was failing with this?
It fails the GTest from bug 1166871.
Depends on: 1193062
This is fixed via bug 1193602.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.