[Smart Collection] Going to task manager from a smart colection, then tapping home button will show a flickering effect, and sometimes will close the smart collection

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: dharris, Unassigned, NeedInfo)

Tracking

({polish, regression})

unspecified
ARM
Gonk (Firefox OS)
polish, regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.2 wontfix, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

Created attachment 8595614 [details]
Smart Collection Flicker Logcat

Description:
Going to task manager from a smart colection, then tapping home button will show a flickering effect, and sometimes will close the smart collection that the user is currently in.


Repro Steps:
1) Update a Flame to 20150421010201
2) Open any Smart Collection
3) Long press Home button> Tap Home button
4) Repeat step 3 a couple times


Actual:
The smart collection will show, then flicker black, then reload the Smart Collection landing page


Expected:
The Smart Collection landing page is smoothly brought into view

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150421010201
Gaia: a8e4f95dce9db727dda5d408b038f97fb4296557
Gecko: 7b823253d9f2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 7/10
See attached: Logcat, Video - https://youtu.be/z7G2t0Ukh2E
This issue DOES occur on Flame 2.2

The smart collection will show, then flicker black, then reload the Smart Collection landing page>
However, on 2.2, the smart collection page will never close. Only the flickering portion of this bug can be seen.

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150421002501
Gaia: 828dd03a0e3b140d74b2e49355197df4d91d9227
Gecko: 36f72a3efb9b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

=============================================================================================================

This issue does NOT occur on Flame 2.1

When tapping the home button in card view from a smart collection, the user is brought straight home without flickering. The flow on 2.1 is different than that of 2.0, 2.2 and 3.0. Therfore not marking a tracking flag for this branch

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150420001205
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: b85d4f4a6d61
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

=============================================================================================================

This issue does NOT occur on Flame 2.0|

The Smart Collection landing page is smoothly brought into view

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150421000202
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: c17fa8ed09c7
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Focusing on it closing out and returning home which is a functional regression.

Requesting a window for when it started closing, if the flickering is related the window will go deeper to 2.2.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: bzumwalt
B2G-Inbound Regression Window

Last working B2G-Inbound build:
Device: Flame 2.2
Build ID: 20140910055313
Gaia: 2f71bd60ff9e50c9821ef96d6a67fbd51f721f2a
Gecko: 15ae5d04c3de
Version: 35.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken B2G-Inbound build:
Device:  Flame 2.2
BuildID: 20140910061313
Gaia: b3698e7e93b5945b5aa5f857dd01932894f57a85
Gecko: b80b5054f126
Version: 35.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Working Gaia with Broken Gecko issue does NOT repro:
Gaia: 2f71bd60ff9e50c9821ef96d6a67fbd51f721f2a
Gecko: b80b5054f126

Working Gecko with Broken Gaia issue DOES reproduce:
Gaia: b3698e7e93b5945b5aa5f857dd01932894f57a85
Gecko: 15ae5d04c3de


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/2f71bd60ff9e50c9821ef96d6a67fbd51f721f2a...b3698e7e93b5945b5aa5f857dd01932894f57a85


Issue appears to occur due to changes made in bug 1061324
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Vivien, can you take a look at this please? This might have been caused by the work done for bug 1061324.
Blocks: 1061324
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(21)
Component: Gaia::Everything.me → Gaia::System::Task Manager
status-b2g-v2.2: affected → wontfix
blocking-b2g: 2.5? → ---
Keywords: polish

Comment 5

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.