Some SIM lock types that should require PUK instead require PIN

RESOLVED FIXED in Firefox 40, Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: pgravel, Assigned: ewu)

Tracking

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

4 years ago
Two of the four lock types added in bug 1113476 (nsckPuk and pckPuk) are improperly requiring PIN entry instead of PUK entry.

dom/icc/Icc.cpp::IsPukCardLockType() needs to be updated with the new lock types in order to pick up the correct password field.

Updated

4 years ago
OS: Unspecified → Gonk (Firefox OS)
Hardware: Unspecified → ARM

Updated

4 years ago
Blocks: 1113476
(Assignee)

Updated

4 years ago
Assignee: nobody → ewu
triage: this breaks functionality
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 2

4 years ago
Created attachment 8595796 [details] [diff] [review]
bug-1157018.patch

add new lock type in order to support NsckPuK and PckPuk.
Attachment #8595796 - Flags: review?(sku)
(Assignee)

Comment 3

4 years ago
Comment on attachment 8595796 [details] [diff] [review]
bug-1157018.patch

Review of attachment 8595796 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Edgar,
Please help review this patch.
thanks.
Attachment #8595796 - Flags: review?(sku) → review?(echen)

Comment 4

4 years ago
Comment on attachment 8595796 [details] [diff] [review]
bug-1157018.patch

Review of attachment 8595796 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, just one thing, please revise the commit title a bit, s/Some SIM lock types/NsckPuk and PckPuk lock types/.
Thank you.

And since this is a 2.2+ blocker, please also help to ask approval after landed in m-c (if this patch is conflict with 2.2 branch, you will need to provide a patch for 2.2).
Attachment #8595796 - Flags: review?(echen) → review+
(Assignee)

Comment 5

4 years ago
Created attachment 8595838 [details] [diff] [review]
Bug 1157018 - NsckPuk and PckPuk lock types that should require PUK instead require PIN.  r=echen
Attachment #8595796 - Attachment is obsolete: true
Attachment #8595838 - Flags: review+
(Assignee)

Comment 6

4 years ago
try is passed.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=5da88f1f3615
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1c4599562e78
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Please request b2g37 approval on this patch when you get a chance.
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
status-firefox38: --- → wontfix
status-firefox39: --- → wontfix
Flags: needinfo?(ewu)
Target Milestone: --- → 2.2 S11 (1may)
(Assignee)

Comment 10

3 years ago
Created attachment 8611035 [details] [diff] [review]
8595838: Bug 1157018 - NsckPuk and PckPuk lock types that should require PUK instead require PIN. r=echenbug-1157018-v2-2.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: IsPukCardLockType() needs to be updated with the new lock types in order to pick up the correct password field.
Testing completed: Verified on master and 2.0m.
Risk to taking this patch (and alternatives if risky): Low, There are no obvious risks I can identify.
String or UUID changes made by this patch:None
Attachment #8595838 - Attachment is obsolete: true
Flags: needinfo?(ewu)
Attachment #8611035 - Flags: review+
Attachment #8611035 - Flags: approval-mozilla-b2g37?

Updated

3 years ago
Attachment #8611035 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.