Intermittent browser_938980_navbar_collapsed.js | application crashed [@ mozilla::dom::indexedDB::`anonymous namespace'::DatabaseOfflineStorage::UnregisterOnOwningThread(already_AddRefed<mozilla::dom::indexedDB::`anonymous namespace'::DatabaseOfflineStora

RESOLVED FIXED in Firefox 39

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: KWierso, Assigned: bent.mozilla)

Tracking

({intermittent-failure})

40 Branch
mozilla40
Unspecified
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s?, firefox38 wontfix, firefox38.0.5 wontfix, firefox39 fixed, firefox40 fixed, firefox-esr31 unaffected, firefox-esr38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(crash signature)

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

4 years ago
15:46:06 INFO - 664 INFO TEST-START | browser/components/customizableui/test/browser_938980_navbar_collapsed.js
15:46:06 INFO - [Child 1852] WARNING: pipe error: 109: file c:/builds/moz2_slave/m-in-w64-000000000000000000000/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 305
15:46:07 INFO - TEST-INFO | Main app process: exit status 1
15:46:07 INFO - 665 INFO checking window state
15:46:07 INFO - 666 INFO Entering test
15:46:07 INFO - 667 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | Test should start with navbar visible
15:46:07 INFO - 668 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | navbar should be hidden now
15:46:07 INFO - 669 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | Customization reset should restore visibility to the navbar
15:46:07 INFO - 670 INFO Leaving test
15:46:07 INFO - 671 INFO Entering test
15:46:07 INFO - 672 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | Everything should be in its default state
15:46:07 INFO - 673 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | Test should start with bookmarks toolbar collapsed
15:46:07 INFO - 674 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | bookmarksToolbar should be collapsed
15:46:07 INFO - 675 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | TabsToolbar should not be collapsed
15:46:07 INFO - 676 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | The nav-bar should be shown by default
15:46:07 INFO - 677 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | bookmarksToolbar should be visible now
15:46:07 INFO - 678 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | navbar should be collapsed
15:46:07 INFO - 679 INFO TEST-PASS | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | Should no longer be in default state
15:46:07 INFO - 680 INFO Console message: [JavaScript Error: "IndexedDB UnknownErr: ActorsParent.cpp:17642"]
15:46:07 WARNING - TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | application terminated with exit code 1
15:46:07 INFO - runtests.py | Application ran for: 0:00:49.835000
15:46:07 INFO - zombiecheck | Reading PID log: c:\users\cltbld~1.t-w\appdata\local\temp\tmpavsf29pidlog
15:46:07 INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/Ol04RnYARq2NeBgsmdGoQA/artifacts/public/build/firefox-40.0a1.en-US.win64.crashreporter-symbols.zip
15:46:14 INFO - mozcrash Saved minidump as C:\slave\test\build\blobber_upload_dir\61f2dbf6-1620-4832-a12b-128b7c85caa0.dmp
15:46:14 INFO - mozcrash Saved app info as C:\slave\test\build\blobber_upload_dir\61f2dbf6-1620-4832-a12b-128b7c85caa0.extra
15:46:14 WARNING - PROCESS-CRASH | browser/components/customizableui/test/browser_938980_navbar_collapsed.js | application crashed [@ mozilla::dom::indexedDB::`anonymous namespace'::DatabaseOfflineStorage::UnregisterOnOwningThread(already_AddRefed<mozilla::dom::indexedDB::`anonymous namespace'::DatabaseOfflineStorage>)]
15:46:14 INFO - Crash dump filename: c:\users\cltbld~1.t-w\appdata\local\temp\tmpnerysw.mozrunner\minidumps\61f2dbf6-1620-4832-a12b-128b7c85caa0.dmp
15:46:14 INFO - Operating system: Windows NT
15:46:14 INFO - 6.2.9200
15:46:14 INFO - CPU: amd64
15:46:14 INFO - family 6 model 30 stepping 5
15:46:14 INFO - 8 CPUs
15:46:14 INFO - Crash reason: EXCEPTION_ACCESS_VIOLATION_WRITE
15:46:14 INFO - Crash address: 0x30
15:46:14 INFO - Thread 29 (crashed)
15:46:14 INFO - 0 xul.dll!mozilla::dom::indexedDB::`anonymous namespace'::DatabaseOfflineStorage::UnregisterOnOwningThread(already_AddRefed<mozilla::dom::indexedDB::`anonymous namespace'::DatabaseOfflineStorage>) [ActorsParent.cpp:02e6a50741a9 : 15395 + 0x7]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbee13c148
15:46:14 INFO - rsp = 0x0000007ae41ff4d0 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: given as instruction pointer in context
15:46:14 INFO - 1 xul.dll!mozilla::dom::indexedDB::`anonymous namespace'::OpenDatabaseOp::ConnectionClosedCallback() [ActorsParent.cpp:02e6a50741a9 : 17918 + 0x1d]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbee121ec6
15:46:14 INFO - rsp = 0x0000007ae41ff500 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 2 xul.dll!nsRunnableMethodImpl<void ( PresShell::*)(void),1>::Run() [nsThreadUtils.h:02e6a50741a9 : 809 + 0x1d]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbee4899e7
15:46:14 INFO - rsp = 0x0000007ae41ff530 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 3 xul.dll!mozilla::dom::indexedDB::`anonymous namespace'::WaitForTransactionsHelper::CallCallback() [ActorsParent.cpp:02e6a50741a9 : 11403 + 0x8]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbee120c9b
15:46:14 INFO - rsp = 0x0000007ae41ff560 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 4 xul.dll!mozilla::dom::indexedDB::`anonymous namespace'::WaitForTransactionsHelper::Run() [ActorsParent.cpp:02e6a50741a9 : 11435 + 0x4]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbee139670
15:46:14 INFO - rsp = 0x0000007ae41ff590 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 5 xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:02e6a50741a9 : 866 + 0x8]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbed1455d1
15:46:14 INFO - rsp = 0x0000007ae41ff5c0 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 6 xul.dll!NS_ProcessNextEvent(nsIThread *,bool) [nsThreadUtils.cpp:02e6a50741a9 : 265 + 0xc]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbed16160b
15:46:14 INFO - rsp = 0x0000007ae41ff7a0 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 7 xul.dll!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate *) [MessagePump.cpp:02e6a50741a9 : 368 + 0xa]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbed33af1c
15:46:14 INFO - rsp = 0x0000007ae41ff7d0 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 8 xul.dll!MessageLoop::RunHandler() [message_loop.cc:02e6a50741a9 : 226 + 0xe]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbed326ca7
15:46:14 INFO - rsp = 0x0000007ae41ff820 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info 
15:46:14 INFO - 9 xul.dll!MessageLoop::Run() [message_loop.cc:02e6a50741a9 : 200 + 0x7]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbed326a72
15:46:14 INFO - rsp = 0x0000007ae41ff850 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 10 xul.dll!nsThread::ThreadFunc(void *) [nsThread.cpp:02e6a50741a9 : 364 + 0x7]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbed14896e
15:46:14 INFO - rsp = 0x0000007ae41ff8a0 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 11 nss3.dll!PR_NativeRunThread [pruthr.c:02e6a50741a9 : 397 + 0x6]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbf11f24a0
15:46:14 INFO - rsp = 0x0000007ae41ff8d0 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 12 nss3.dll!pr_root [w95thred.c:02e6a50741a9 : 90 + 0x5]
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbf11e338a
15:46:14 INFO - rsp = 0x0000007ae41ff900 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 13 msvcr120.dll + 0x24f7e
15:46:14 INFO - rbx = 0x0000007ae99386a0 r12 = 0x0000000000000000
15:46:14 INFO - r13 = 0x0000000000000001 r14 = 0x0000007ae41ff7d0
15:46:14 INFO - r15 = 0x0000000000000000 rip = 0x000007fbfcf14f7f
15:46:14 INFO - rsp = 0x0000007ae41ff930 rbp = 0x0000007ae41ff6c0
15:46:14 INFO - Found by: call frame info
15:46:14 INFO - 14 msvcr120.dll + 0x25125
15:46:14 INFO - rip = 0x000007fbfcf15126 rsp = 0x0000007ae41ff960
15:46:14 INFO - Found by: stack scanning
15:46:14 INFO - 15 msvcr120.dll + 0xdcb7f
15:46:14 INFO - rip = 0x000007fbfcfccb80 rsp = 0x0000007ae41ff968
15:46:14 INFO - Found by: stack scanning
15:46:14 INFO - 16 kernel32.dll + 0x167d
15:46:14 INFO - rip = 0x000007fc075a167e rsp = 0x0000007ae41ff990
15:46:14 INFO - Found by: stack scanning
15:46:14 INFO - 17 ntdll.dll + 0x1c3f0
15:46:14 INFO - rip = 0x000007fc0a14c3f1 rsp = 0x0000007ae41ff9c0
15:46:14 INFO - Found by: stack scanning
15:46:14 INFO - 18 KERNELBASE.dll + 0x809cf
15:46:14 INFO - rip = 0x000007fc074c09d0 rsp = 0x0000007ae41ff9f0
15:46:14 INFO - Found by: stack scanning
15:46:14 INFO - Thread 0
Comment hidden (Legacy TBPL/Treeherder Robot)
Summary: Intermittent browser_938980_navbar_collapsed.js | application crashed → Intermittent browser_938980_navbar_collapsed.js | application crashed [@ mozilla::dom::indexedDB::`anonymous namespace'::DatabaseOfflineStorage::UnregisterOnOwningThread(already_AddRefed<mozilla::dom::indexedDB::`anonymous namespace'::DatabaseOfflineStora
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
This is extremely frequent on Windows e10s.
tracking-e10s: --- → ?
Flags: needinfo?(bent.mozilla)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Duplicate of this bug: 1157785
Probably fallout from bug 1156063.
Flags: needinfo?(bent.mozilla)
Comment hidden (Legacy TBPL/Treeherder Robot)
Posted patch Patch, v1 (obsolete) — Splinter Review
Ok, this is better. I don't know why I didn't do this before. We *always* go through SendResults (otherwise bad stuff happens) so putting the cleanup code there is safest.
Assignee: nobody → bent.mozilla
Status: NEW → ASSIGNED
Attachment #8596800 - Flags: review?(Jan.Varga)
Posted patch Patch, v1Splinter Review
Forgot to qref that other one.
Attachment #8596800 - Attachment is obsolete: true
Attachment #8596800 - Flags: review?(Jan.Varga)
Attachment #8596802 - Flags: review?(Jan.Varga)
Oh, and the problem with the previous approach was that we could call ActorDestroy and then SendResults (or in the reverse order) with mOfflineStorage set. That would trigger two WaitForTransactionsHelper events to get queued, and the first would clean up and the second would crash. Boo.
Comment on attachment 8596802 [details] [diff] [review]
Patch, v1

Review of attachment 8596802 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, this looks cleaner.
Attachment #8596802 - Flags: review?(Jan.Varga) → review+
Comment hidden (Legacy TBPL/Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/12409cbb8d61
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
I assume this will need to be rebased on top of any branch patch from bug 1156063.
Flags: needinfo?(bent.mozilla)
This missed Fx38 due to the lack of a rebased patch. Hopefully we can still get this on esr38...
Posted patch Branch patchSplinter Review
Patch for 38
Flags: needinfo?(bent.mozilla)
Attachment #8601109 - Attachment description: changes.patch → Branch patch
Comment on attachment 8601109 [details] [diff] [review]
Branch patch

This is needed for bug 1156063.
Attachment #8601109 - Flags: approval-mozilla-esr38?
Attachment #8601109 - Flags: approval-mozilla-b2g37?
Attachment #8601109 - Flags: approval-mozilla-aurora?
Comment on attachment 8601109 [details] [diff] [review]
Branch patch

Approving for uplift since this needs to go along with the uplift for bug 1156063.
Attachment #8601109 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
This patch is fine and will reland with the others soon.
Comment on attachment 8601109 [details] [diff] [review]
Branch patch

Keeping the risk in mind and backing out if causing any side effect.
Attachment #8601109 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8601109 - Flags: approval-mozilla-esr38? → approval-mozilla-esr38+
You need to log in before you can comment on or make changes to this bug.