Closed Bug 1157087 Opened 5 years ago Closed 4 years ago

Pause doesn't pause on YouTube MSE videos

Categories

(Core :: Audio/Video: Playback, defect)

40 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox40 --- affected

People

(Reporter: cajbir, Unassigned)

References

(Blocks 1 open bug)

Details

When playing youtube video then pausing the video doesn't pause. Instead it slows down to one or two frames per second and the buffering bar oscillates between growing and shrinking.

Steps to Reproduce:

1) Load http://www.youtube.com/watch?v=3V7wWemZ_cs
2) Play video
3) Pause video

What happens:

4) Video pauses but then advances one or two frames per second with oscillating buffer bar.

What should happen:

5) Video should pause.

This is on a mozilla-central build - it did not occur with a build from yesterday.
I may be wrong about the "did not occur with a build from yesterday". Problem shows in nightly and aurora builds. It does not show in release build.
Further investigation shows this to be Linux only, where MSE isn't enabled in release. Testing with MSE enabled shows the issue on Release builds. I've been unable to find a 'good' build that doesn't show it going back to beginning of march.
Blocks: MSE
I can't reproduce this on Fedora 22 on Firefox 39 with mse enabled except vp9
Component: Audio/Video → Audio/Video: Playback
the entire MSE stack was rewritten
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.