Closed Bug 1157089 Opened 9 years ago Closed 8 years ago

[gcli] Provide a way to search preferences

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect)

37 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: strugee, Unassigned)

References

Details

GCLI should provide a way to search preferences, similar to `addon list`, except that you should be able to pass it a string (or regexp) to filter by.
Blocks: GCLICMD
The command "pref show " looks works, it have automatic suggestions for all pref name.
Flags: needinfo?(alex)
Personally I find that I often remember a single component of a pref's path, which is probably not at the beginning. So the autocomplete doesn't work for that because the typed string isn't at the beginning of the pref name.
Flags: needinfo?(alex)
According to my test results, it is an any match instead of begin match only, although it does not support any wildcard or regexp.
Right, this works as designed in comment 3.
Thanks
Triage. Filter on Lobster Thermidor.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.