Hysteresis in scroll wheel handling causes viewport to shift

RESOLVED FIXED

Status

()

Core
Panning and Zooming
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
Unspecified
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 affected)

Details

(Whiteboard: gfx-noted)

(Reporter)

Description

3 years ago
STR:

1) open http://www.techmeme.com/
2) let the page load
3) scroll down half way, place an article in the center, and place your mouse near it (but over white space) so you can track changes in page position.
4) roll your scroll wheel forward and back evenly without removing your finger from the wheel, do this slowly multiple times.
5) stop and let the page scroll settle.

expected: When you stop and the wheel is in its starting position, the article you were tracking should be back at original position.

result: I end up all over the place in the document. Usually the page ends up near the top.
(Reporter)

Comment 1

3 years ago
Also, this might depend on precision scroll mice. Notched mice not reproduce. I tried to reproduce this on a Surface Pro with an inexact external mouse attached and couldn't.
Blocks: 1154459
No longer blocks: 1154825
Whiteboard: gfx-noted
Component: Graphics → Panning and Zooming
Does this still happen? It may have been fixed by bug 1157409.
Flags: needinfo?(jmathies)
(Reporter)

Comment 3

3 years ago
I can't test, scrolling with the mouse wheel hangs the browser - https://crash-stats.mozilla.com/report/index/ad958dc0-b622-47a3-824d-95f702150504
(Reporter)

Updated

3 years ago
Flags: needinfo?(jmathies)
I filed bug 1161040 for the hanging issue.
Depends on: 1161040
Hey, sorry to keep bugging you - can you re-test now? The hanging issue should be fixed.
Flags: needinfo?(jmathies)
(Reporter)

Comment 6

3 years ago
sorry this will have to wait a bit longer as I'm in the middle of a move, so the mouse/system in question are in a box until June.
(Reporter)

Comment 7

3 years ago
seems to be fixed
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jmathies)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.