Closed Bug 1157463 Opened 7 years ago Closed 7 years ago

Target desktopRT from WebIDE

Categories

(DevTools Graveyard :: WebIDE, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1038533

People

(Reporter: nick, Unassigned)

References

Details

In order to use the privileged APIs, an app has to be signed by marketplace. This is not an issue when developing for FxOS, as we have the simulator to simulate privileged APIs.  When developing for Firefox Web Runtime on a desktop platform, this is a huge issue, as one cannot test the use of privileged APIs in a developer environment.  Developers end up submitting apps that aren't even tested, then fail review, so they still can't download a signed app to test.

If the developer was able to install local to the host OS to test their desktop runtime app, this might alleviate the issue.  I can imagine a developer opening the webIDE, then in the drop down, rather than choosing a version of the simulator, picking "desktopRT" or something.

* https://developer.mozilla.org/en-US/Marketplace/Options/Self_publishing#Limitations
* https://developer.mozilla.org/en-US/docs/Web/API/DOMApplicationsRegistry/installPackage
* https://developer.mozilla.org/en-US/docs/Web/API/DOMApplicationsRegistry/install
Doesn't using the Remote Runtime option work for WebRT? I think you have to start WebRT with "--debug 6000" or similar first.
`-debug <port>` works, once the app is already installed.  The problem is, how do you even install a privileged packaged app on desktop that has not been signed by marketplace, which you might want to do if you were developing such an app?  You can't.
We have at least 2 app developers that are working on privileged apps for Desktop that are blocked by this and always have to submit to Marketplace and wait for review for testing.
I believe this is a duplicate of bug 1038533, does that seem right?
Also, is there someone working on desktop RT that could be mentored to work on this?
I'll mark as duplicate for now.  Feel free to reopen if I've misunderstood.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1038533
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.