Closed Bug 1157488 Opened 5 years ago Closed 5 years ago

Assert against re-entrant sync sections

Categories

(Core :: Widget, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: bholley, Assigned: bholley)

References

Details

Attachments

(2 files)

This was the source of a hard-to-track-down bug in bug 1144486.
Attachment #8596225 - Flags: review?(bent.mozilla)
Comment on attachment 8596225 [details] [diff] [review]
Assert against re-entrant sync sections. v1

Review of attachment 8596225 [details] [diff] [review]:
-----------------------------------------------------------------

Ok
Attachment #8596225 - Flags: review?(bent.mozilla) → review+
(In reply to Bobby Holley (:bholley) from comment #3)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=f2dc4df4d3c6

Followup for the android orange, which was caused by not having the patch from comment 4:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e443c209dcc2
Attachment #8596287 - Flags: review?(jwwang) → review+
https://hg.mozilla.org/mozilla-central/rev/e436e20e5f2c
https://hg.mozilla.org/mozilla-central/rev/7cd7611ed7b3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Depends on: 1158761
Depends on: 1165350
You need to log in before you can comment on or make changes to this bug.