Closed Bug 115770 Opened 21 years ago Closed 3 years ago

Scoped stylesheets use the wrong load group!

Categories

(Core :: XBL, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: hyatt, Unassigned)

References

Details

This is the cause of onload beating constructors in XBL.  Scoped stylesheets 
can end up using the wrong load group (or no load group at all).

Very bad.
accepting.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8
Target Milestone: mozilla0.9.8 → mozilla0.9.9
->future, per hyatt
Target Milestone: mozilla0.9.9 → Future
How is this "very bad" as in the original description?  Enquiring minds want to
know, so as to calibrate "bad, fix for 1.0", "very bad, must fix for 1.0", and
"very bad, but future". :-).

/be
Hmm... So the problem here is that the loadgroup of the binding document itself
is used, no?  And since this document has in fact finished loading by the time
the resources are being loaded, that doesn't help any....

The problem is made worse by the fact that multiple normal documents can be
trying to get the same binding at once, so that the XBL code needs to be able to
hold up onload events for multiple callers or something.

As for how bad the very bad is, it's blocking work on firing load events for
stylesheets, if nothing else.  The problem is "solved" for chrome by loading
everything synchronously, but for general XBL it's a major issue.
Blocks: 185236
QA Contact: jrgmorrison → xbl
Assignee: hyatt → nobody
This is a mass change. Every comment has "assigned-to-new" in it.

I didn't look through the bugs, so I'm sorry if I change a bug which shouldn't be changed. But I guess these bugs are just bugs that were once assigned and people forgot to change the Status back when unassigning.
Status: ASSIGNED → NEW

XBL is now disabled in Firefox (Bug 1583314) and is in the process of being removed from Gecko (Bug 1566221), so closing bugs requesting changes to its implementation as wontfix.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.