Windows 10 - Tabbar icons and background tab text should not get inverted for dark color themes

VERIFIED FIXED in Firefox 39

Status

()

P1
normal
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: ntim, Assigned: ntim)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 41
All
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38 wontfix, firefox39 verified, firefox40 verified, firefox41 verified, firefox-esr38 verified)

Details

(Whiteboard: [fixed by bug 1166867])

Attachments

(1 attachment)

Created attachment 8597395 [details]
Screenshot (70).png

In the latest Win 10 build, all titlebars are using a gray background. So it makes no sense inverting the tab bar icons and the background tabs text color.
Blocks: 1077146
Assignee: nobody → ntim.bugs
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 1166867
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1166867]
status-firefox38: --- → wontfix
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → fixed
Target Milestone: --- → Firefox 41
status-firefox39: affected → fixed
status-firefox40: affected → fixed
status-firefox-esr38: --- → fixed
Flags: qe-verify+
I'm not sure exactly what Windows 10 build this issue was reproducing on, but I was _unable_ to replicate it on an affected Firefox build (40.0a1 2015-04-24) with Windows 10 Pro Insider Preview (build 10130).

This seems to be verified fixed on:
* Nightly 41.0a1 (2015-06-14), 
* Aurora 40.0a2 (2015-06-14), 
* Beta 39.0b5 (20150611135623)
* ESR 38.0.1 (20150514102509), 
where the tab bar's colors are displayed properly, using light, dark and high-contrast themes.
Status: RESOLVED → VERIFIED
status-firefox39: fixed → verified
status-firefox40: fixed → verified
status-firefox41: fixed → verified
status-firefox-esr38: fixed → verified
Flags: qe-verify+
(In reply to Andrei Vaida, QA [:avaida] from comment #1)
> I'm not sure exactly what Windows 10 build this issue was reproducing on,
> but I was _unable_ to replicate it on an affected Firefox build (40.0a1
> 2015-04-24) with Windows 10 Pro Insider Preview (build 10130).
Thank you for the verification ! You need to set your theme color to a very dark color like black or dark blue, then restart Firefox.
You need to log in before you can comment on or make changes to this bug.