Closed Bug 1158692 Opened 5 years ago Closed 5 years ago

[Flame][Music]After a song plays over, the Music will crash.

Categories

(Firefox OS Graveyard :: RTSP, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:2.5+, firefox40 fixed, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.5+
Tracking Status
firefox40 --- fixed
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: wangxin, Assigned: sotaro)

References

Details

(Keywords: crash, regression, smoketest)

Crash Data

Attachments

(3 files, 2 obsolete files)

[1.Description]:
The Crash happens on Music app
[Flame][v3.0][Music]Play a song from music playlist, then after the song plays over, the Music app will crash.
Here are the detailed information:
--Title:
  ~ B2G 40.0a1 Crash Report [@ mozilla::AudioSink::~AudioSink() ]
--Crash Report: 
  ~https://crash-stats.mozilla.com/report/index/17507946-0e09-430b-a4ac-8eb652150427
Found time:20:42
See log:"logcat_2042.txt"
See video:"2042.mp4"

[2.Testing Steps]: 
Prerequisite: There are some musics in device.
1. Launch Music.
2. Play a song  from music list.
3. Wait for this song to play over.

[3.Expected Result]: 
3. Device should load to play list view.

[4.Actual Result]: 
3. The Music app will crash.

[5.Reproduction build]: 
Flame 2.2 version(Unaffected):
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.043030
Firmware Date          Sun Apr 26 04:30:42 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Affected):
Build ID               20150426160201
Gaia Revision          b4c949cdc780893897c9b45c1adea46e2eb694ff
Gaia Date              2015-04-24 16:13:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d60e3b8be6
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150426.193323
Firmware Date          Sun Apr 26 19:33:34 EDT 2015
Bootloader             L1TC000118D0

Nexus5_2.2(Unaffected):
Build ID               20150426002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150426.042708
Firmware Date          Sun Apr 26 04:27:25 EDT 2015
Bootloader             HHZ12f

Nexus5_3.0(Unaffected):
Build ID               20150426160201
Gaia Revision          b4c949cdc780893897c9b45c1adea46e2eb694ff
Gaia Date              2015-04-24 16:13:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37d60e3b8be6
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150426.193304
Firmware Date          Sun Apr 26 19:33:21 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video Bug video: 2042.mp4
Upgrading to a smoketest blocker
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: smoketest
[Blocking Requested - why for this release]:
Functional regression resulting in a crash that fails smoke tests.

Window already requested.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qaurgent
QA Contact: bzumwalt
Central Regression window:

From the pushlog and failed attempt to find window in Mozilla-Inbound, this issue appears to have its genesis on the fx team branch. Looking for deeper window there, will post when I finish.


Last working Central build:
Device: Flame 3.0
Build ID: 20150423141101
Gaia: 0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gecko: 22a157f7feb7
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First broken Central build:
Device:  Flame 3.0
BuildID: 20150424053759
Gaia: 5d416244c0d9cbbb5823e872ac4b03addeb59bad
Gecko: 86d3308ec888
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Working Gaia with Broken Gecko issue DOES reproduce:
Gaia: 0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gecko: 86d3308ec888

Working Gecko with Broken Gaia issue does NOT reproduce:
Gaia: 5d416244c0d9cbbb5823e872ac4b03addeb59bad
Gecko: 22a157f7feb7


Central Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=22a157f7feb7&tochange=86d3308ec888
Bug 1145052 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150423142501
Gaia: 04738cac27a6676fad7147b4d769605fb0dcbb3e
Gecko: c6d66d6b2606
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150423151158
Gaia: 04738cac27a6676fad7147b4d769605fb0dcbb3e
Gecko: 2537f573b7ab
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 04738cac27a6676fad7147b4d769605fb0dcbb3e
Gecko: 2537f573b7ab

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 04738cac27a6676fad7147b4d769605fb0dcbb3e
Gecko: c6d66d6b2606

Gecko Pushlog: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=c6d66d6b2606&tochange=2537f573b7ab
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Jonathan, can you take a look at this please? Looks like the landing for bug 1145052 is causing a reproducible smoke test blocking crash. We need this backed out asap if this indeed is the cause.
Blocks: 1145052
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(jhao)
I suspect it is caused by AudioSink's naming conflict. I already created a fix as part of Bug 1158293.

In gecko media, there are 2 AudioSinks. They are the followings. 

  https://dxr.mozilla.org/mozilla-central/source/dom/media/AudioSink.h#18
  https://dxr.mozilla.org/mozilla-central/source/dom/media/omx/AudioSink.h#42
Sotaro, it sounds like you're trying to make a patch to fix the issue rather than for us to backout.  Is that correct?
Flags: needinfo?(sotaro.ikeda.g)
Blocks: 1158293
I am going to fix actual problem. My fix is orthogonal to back-out.
Flags: needinfo?(sotaro.ikeda.g)
Attachment #8598255 - Attachment is obsolete: true
Attachment #8598261 - Flags: review?(cpearce)
same result, but simpler patch. Easier to check diff than previous one.
Attachment #8598261 - Attachment is obsolete: true
Attachment #8598261 - Flags: review?(cpearce)
Attachment #8598361 - Flags: review?(cpearce)
Attachment #8598361 - Flags: review?(cpearce) → review+
Remove ni of mine since Sotaro has a fix.
Flags: needinfo?(jhao)
Assignee: nobody → sotaro.ikeda.g
verified fix on inbound.  need to wait for releng build to have this on master. ( 4pm build? )
https://hg.mozilla.org/mozilla-central/rev/67cb93edea83
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S11 (1may)
Adding qawanted to verify this fix with next available central.
QA Whiteboard: [QAnalyst-Triage+]
This issue is verified fixed on Flame 3.0

The user is able to listen to the entirety of a song, and then play the next song, as well as simply skip to the next song, and the music app will not crash. Also sliding the music scrubber all the way to the end of a song will initiate the next song in the list without crashing.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150429010205
Gaia: 6e35b0948c42a4398b8a5916015de167121683a1
Gecko: 1ad65cbeb2f4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Crash Signature: [@ mozilla::AudioSink::~AudioSink() ]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Moving the bug to the component where the regression came from.
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Music → RTSP
You need to log in before you can comment on or make changes to this bug.